Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: Teensy 3.5 with RGB Matrix Panel and Audio Shield

  1. #1
    Junior Member
    Join Date
    Apr 2018
    Posts
    2

    Teensy 3.5 with RGB Matrix Panel and Audio Shield

    Hi,

    I like to set a project with a Teensy 3.5, two 64 x 32 RGB-Panels and the Teensy Audio Shield. We want to use the Display to play text and play a song over the audio shield in order to use it for karaoke.

    I achieved to use the displays as 64 x 64 and the audio shield for themselves. I canít use them simultaneously because they are sharing seven pins.

    In order to solve that problem I like to change the pins used by the SmartMatrix library to unused pins on the teensy 3.5 (unused PWM-Pins are 29-30 and 35-38). Unfortunately the pin assingment (GPIO_PIN_XX_TEENSY_PIN) in MatrixHardware_KitV1.h seems to have no effect. I already aksed in the SmartMatrix forum, but they told me to ask here for support in changing the pins.

    Has someone else used this combination or does someone know how to change the pin assignment?

    Kind regards
    Franz

  2. #2
    The SmartMatrix Shield V4 for Teensy uses fewer pins than previous versions (by using an external latch to hold the ADDX lines instead of driving via GPIO), and has untested partial compatibility with the Teensy Audio Shield. Franz posted on the SmartMatrix Community as well, and I gave him some advice there: http://community.pixelmatix.com/t/us...io-shield/266/

  3. #3
    Junior Member
    Join Date
    Oct 2018
    Posts
    1
    Sorry for replying to this "old" thread.

    But Franz, can you tell us if it worked out?

    Actually i am working too on a dot matrix and sound project with this two shields.

    It works for me with a downside...
    As soon as i use a matrix, the audio gets a beeping tone to it.

    I tried a bit and ended up at the clock pin for the matrix.
    As soon i connect it(Only with gnd), the tone gets even louder.

    I use the build in SD-Card.

    So my final Question:

    Franz did you solve this problem? Did you have the same issues?

    Kind regards,
    Kevin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •