Forum Rule: Always post complete source code & details to reproduce any issue!
Page 3 of 3 FirstFirst 1 2 3
Results 51 to 56 of 56

Thread: USBHost_t36 Midi InputFunctions example is not working for me... Hardware issue?

  1. #51
    Quote Originally Posted by PaulStoffregen View Post
    My best guess, again, is very likely a power problem. Can you give more info about how Teensy 3.6 is getting power? Is is plugged directly into a PC? Or into a hub? Is that hub powered or unpowered (getting power only on its USB cable to the PC)?

    Maybe try using a voltmeter to check the VIN pin, to see how much voltage Teensy 3.6 is receiving. Also (very carefully) check the 5V output on the host port, to see how much voltage Teensy is giving to your hub to run. My guess is these will probably show voltages much less than 5 volts.
    Ok, so here's what I found out:

    Teensy 3.6 getting power directly via USB from Macbook; nothing else connected to Teensy.
    -> VIN pin on Teensy: 5.18 V
    -> 5V Pin on host port: 4.85 V

  2. #52
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Wow, so that hub is getting 4.85 volts from Teensy, and giving only 3.6V to the downstream USB devices. Not good. Maybe find a better hub? Or give it external power.

  3. #53
    Hm maybe I am totally misunderstanding something. Sorry for that … still learning.
    In the setup for the measurements above the hub was not connected. I only had the Teensy connected to the Macbook via USB.
    Last edited by uleria; 03-13-2019 at 08:55 PM. Reason: Typo

  4. #54
    Junior Member
    Join Date
    Jan 2014
    Thanks a lot Paul!

    It's the second time I've worked with the OP-1 and the Teensy as USB Host. First time with a very old usb-hub: There was no problem. The second time I used a cheap but new Hama USB 2.0 hub and it only worked after using MIDIDevice_BigBuffer. Power was not the problem in my case.

    I have to add that it was two different OP-1's. I guess the later one is newer.

  5. #55
    Junior Member
    Join Date
    Nov 2020
    Just in case someone like me finds themselves here: I was having the same results as uleria - but I figured out it was because I made my own USB host cable. When looking online at USB wire colors it shows green is Data- and white is Data+ BUT you actually want to hook white up to Data- and green to Data+... Hope this can save someone out there some time and debugging!

  6. #56
    I have seen in the beginning of the thread that novation launchpad is not working. Is it still the case or is there a work around? (i have the mk1)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts