Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 2 of 2

Thread: Glitches in audio when writing to TFT

  1. #1

    Glitches in audio when writing to TFT

    I have noticed that I get glitches in the audio coming from the Audio Adapter when writing data to a TFT-screen (connected with alternate pins 20/21 recommended by PJRC website). The Audio Adapter and the TFT share pin 7 (SDI) and pin 14 (SCK), could this be the reason to the glitches?

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    17,475
    First to answer your question:

    The Audio Adapter and the TFT share pin 7 (SDI) and pin 14 (SCK), could this be the reason to the glitches?
    No, that alone does not explain it.

    Without seeing what you're doing (eg, posting the code) I can only guess. So here's some guesswork.

    If you're playing from a SD card, the sharing of the SPI for both TFT and SD could be an issue. Usually this works, but it's possible you're doing something special.

    Or it may be you're doing TFT operations that take too much time. But unless the audio lib is also using the SPI, the TFT drawing isn't supposed to block the audio from updating. If you're not using any SPI chips or SD card, then there may be some unknown bug.

    But all of that is just blind guesswork. Without seeing the code, impossible to really know.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •