Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 4 of 4

Thread: Teensy upload problem

  1. #1
    Junior Member
    Join Date
    Jul 2016
    Posts
    6

    Teensy upload problem

    I recently tried to upload to my Teensy 3.2 and got the dreaded “Teeny did not respond” message. I tried several Teensy’s all with the same result. Even the Examples “Blink” program won’t upload.

    Under Tools in the menu I have:
    Tools - Board: “Teensy 3.1”
    Tools - USB Type: “Serial”
    Tools - Port: “/dev/cu.RNBT-345C-RNI-SPP”

    The only other port available is “/dev/cu,Bluetooth-Incomeing-Port”

    I normally see something like “dev/cu.usbmodem1866971”

    I’m on a Mac running macOS High Sierra v 10.13.5. there have been several updates lately.

    Thanks!

  2. #2
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    11,522
    Did you try the Program Button? To what end?

    What version of TeensyDuino? The newest 1.42 has better feedback on Teensy being present in any USB or Bootloader mode.

    Sounds like a bad cable or some USB fail - has VUSB<>VIN trace been cut?

  3. #3
    Junior Member
    Join Date
    Jul 2016
    Posts
    6
    Thanks defragster, you were correct, bad cable.

  4. #4
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    11,522
    Nice simple fix. Did that cable work well before or was it always just a power only cable?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •