Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 4 of 4

Thread: AltSoftSerial Library in Linux

  1. #1
    Junior Member
    Join Date
    Aug 2018
    Posts
    2

    AltSoftSerial Library in Linux

    Hi, I had installed this library in Linux plataform. Whe I started up arduito IDE the message appear:
    Te library "AltSoftSerial-master" cannot be used. Library names must contain only basic letters and numbers. (ASCII only and no spaces, and it cannot start with a number)
    Click image for larger version. 

Name:	img97.jpeg 
Views:	25 
Size:	14.4 KB 
ID:	14491

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,554
    What version of Arduino are you using? Click Help > About to check. Maybe it's something ancient like 1.0.5 or 1.0.6?

  3. #3
    Junior Member
    Join Date
    Aug 2018
    Posts
    2
    It is "1.0.5".

  4. #4
    Senior Member+ Theremingenieur's Avatar
    Join Date
    Feb 2014
    Location
    Colmar, France
    Posts
    2,530
    First step would be to update, using the current Arduino version 1.8.5 and the Teensyduino 1.4.2 plugin.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •