Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 5 of 5

Thread: Multiple Teensy not recognized anymore

  1. #1
    Junior Member
    Join Date
    Aug 2015
    Posts
    9

    Multiple Teensy not recognized anymore

    Hello,

    I have some problems with ALL of my Teensys. I have a 3 Teensy 3.1 and 1 Teensy 3.6

    They have been in the drawer for some time but I know that all of them were working, the last time I used them. I don`t know what the last software was that they were running but I think it were MIDI devices.

    Today I wanted to use one of them again and it was not recognized by the PC. Then I tried the next one and then the next and then the last one and none of them is recognized anymore.

    I tried 5 different cables and non of them were working (these are no charging cables, all my STM boards are working with all of the cables).

    I tried 3 different PCs. One is running WIN7, one is running WIN10, and one is running WIN10 and xubuntu. None of them is showing any device when I plug in the teensys. In the device Manager of the Windows PC is no new device shown and lsusb on Linux is also showing no device.

    I tried pushing the Reset button while plugin in the teensys to flash the blink example but it is not working.

    The devices are neither shown as MIDI nor as Serial nor as HID device... They are simply not recognized by any OS with any cable with any configuration... I tried everything that I could find in any threads here or elsewhere

    What could I try next? This is really frustrating because I always loved the Teensy boards but now they are really giving me a hard time...

    Any suggestions?

    Thanks in advance

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    18,696
    Maybe try running "tail -f /var/log/syslog" on that Linux machine. The Linux kernel messages about USB events are usually the most informative way to get more info. (must be running on real hardware for useful info, not within a virtual machine)

    Seems very unlikely that 4 boards would all mysteriously fail. But then you've covered pretty much everything in your message, so not much left to suggest. The Linux kernel messages will at least tell you if *something* is happening.

    Maybe also use a voltmeter and check that the boards have 3.3V power. Again, hard to imagine how other stuff would work and Teensy wouldn't, but if the hardware is good and has proper power, pressing the Program (not Reset) button should cause the board to run the bootloader and appear as a HID device.

  3. #3
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    7,109
    That is Odd. Note: the button is 'Program' not Reset. Yes, it should take the Teensy offline to show as a HID device and ready to be programmed.

    Don't know about xubuntu - but Windows can get confused with rapid device swapping/removal when it was looking to see what it was … confused or belligerent - it seems to put that device or port on 'time out' for some minutes.

    If the cable is put on a 'new' USB port and then the Teensy is plugged in while holding the button a second before releasing it - then letting it untouched 5-20 seconds it should be picked up as a HID device?

    What version of IDE and TeensyDuino are installed? The version 1.42 to 1.44 of TeensyDuino have PJRC custom Teensy device recognition code that will better ID the device on the Tool/Port menu. Also running TeensyLoader - opening Help/Verbose gives a window that will show detection and details of any arriving device.

  4. #4
    Junior Member
    Join Date
    Aug 2015
    Posts
    9
    So I have news regarding the Teensys. I brought All of them to my work and tried them on my work PC. All of them were recognized and I have been able to Flash the "blink" Firmware. I did nothing special, just plugged them in and "boom" instantly working.

    I will check if they are working now on my home PC later and will give you feedback.

    But I still think it is really strange, that they were not working on 3 different PCs with different Operating Systems before...

  5. #5
    Junior Member
    Join Date
    Aug 2015
    Posts
    9
    Back at home, plugging in the Teensy devices and now they are recognized by all PCs. No pushing the "Program" button, just plugging in and they are working.

    I don`t know why they were not recognized before by 4 different PCs but now they are working.

    So if anybody faces the same Problems like me (not working at all or even not working by plugging in with the program button pushed) just try more PCs and maybe they will get recognized and you can fix them (which for me was just uploading the blink example)

    Thank you for your help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •