Forum Rule: Always post complete source code & details to reproduce any issue!
Page 4 of 4 FirstFirst ... 2 3 4
Results 76 to 82 of 82

Thread: USB Audio Clicking Noise

  1. #76
    Senior Member
    Join Date
    Apr 2014
    Posts
    302
    This works perfectly now that the #ifdefs are added...........

  2. #77
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    4,773
    Great!
    Does it work with Linux, too?

  3. #78
    Senior Member
    Join Date
    Apr 2014
    Posts
    302
    Yes, works on Linux Lubuntu 18.04 and windows 10 on Pentium. Both behave similar.
    Tested with setI2S_freq at ..... 44000, 44100, 44112 and all worked no clicks. Tested at 44116 for both and heard clicks.
    Didn't try winXP but should be OK, should be same.

  4. #79
    Senior Member
    Join Date
    Apr 2014
    Posts
    302
    Tried on Windows XP and clicking is still there. Plays about 6 seconds clear and then clicking starts.
    I am replacing my windows XP so for me not worth pursuing this XP problem any further. Windows 10 and Linux work well now.

    If I compile and program teensy on Windows XP I get clicks when recorded and played back on both windows XP and windows 10 machines.

    If I compile and program teensy on windows 10 I get clear recording no clicks when recorded and played back on both windows 10 and windows XP machines.
    Last edited by Teenfor3; 11-26-2018 at 01:30 AM. Reason: added 2 lines about compiling on either machine

  5. #80
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    4,773
    Thank you for testing! I don't care about XP.

  6. #81
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    18,691
    I have no plans to ever test this on Windows XP or Vista. When I do work on it, which very likely may be late in 2019, the oldest version I'm going to test will be Windows 7.

  7. #82
    Senior Member+ Theremingenieur's Avatar
    Join Date
    Feb 2014
    Location
    Colmar, France
    Posts
    2,068
    Sorry, have been absent for a few days, had to teach music in Germany. Will give FrankB's workaround a try on macOS very soon.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •