Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: MCUExpresso with Debugger Configuration?

  1. #1
    Junior Member bss_hmr's Avatar
    Join Date
    Nov 2018
    Posts
    3

    MCUExpresso with Debugger Configuration?

    Has anyone set up the Teensy Core libraries in MCUXpresso or other eclipse environment? I modified the Teensy 3.5 hardware for debugging and can successfully load the default 'hello world' program to the teensy, cannot figure out how to configure the eclipse environment to allow me to use the arduino libraries.

    Thanks in advance!

  2. #2
    I don't know the MCUExpresso environment but i can give you the basic steps for the GNU MCU C/C++ plugin and its probably more or less the same. First copy the entire Teensy source to a sub folder in you eclipse project and press F5 for refresh.

    Example:
    cp -R /usr/share/arduino/hardware/teensy/avr/cores/teensy3/* /your-eclipse-project/teesy3

    Then right click in Eclipse on the directory and select properties and "C/C++ Build" and uncheck "Exclude resource from build" if it is checked. Afterwards you only have to add the directory to your compiler include path and set the correct compiler options, cpu, etc... in Project / properties / C/C++ Build / Settings. See the makefile in the teensy3 directory to get the correct options.

    Good luck..

  3. #3
    Junior Member bss_hmr's Avatar
    Join Date
    Nov 2018
    Posts
    3
    A coworker of my was able to get it up and running by following the steps on this blog post

    https://thefirebrandforge.com/page/s...de-for-teensy/

    Getting all the configuration settings and linker set up correctly is a nightmare. If you are struggling setting it up I strongly recommend following these steps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •