Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 5 of 5

Thread: USB connecter dettached from my Teensy 3.2

  1. #1
    Junior Member
    Join Date
    Nov 2018
    Posts
    2

    USB connecter dettached from my Teensy 3.2

    Hi. I'm a new forum member. I searched the forum and searched the FAQ for a similar issue but did not find one. Sorry if I missed it.

    The USB connector on my Teensy 3.2 just "fell off". I was applying pressure to connect a USB cable to the board when the USB connector detached from the board. The connector was not pried up - it simply detached from the board in the direction of connector insertion.

    Any recourse? I'm not sure if its possible to re-solder this part to the board - the pins appear to be in satisfactory condition, but with the big pads under the connector, I see no way to re-flow the solder.

    Thanks,

    - Homarne

  2. #2
    Member crees's Avatar
    Join Date
    Dec 2016
    Location
    Utah
    Posts
    94
    it happens. I have taught robotics classes using the 32u4 chip (from Bangood) and have had a handful of usb connectors pop off. however all of my teensies have been very well built and have had no issues

    If you feel it was do to a defect I would contact the seller and see if they can swap it out.

  3. #3
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    7,055
    There are posts on getting USB back online. Typically using the bottom pads - there is an OSH board IIRC that solders to them and mounts with a fresh connector.

    Should come up in a search with Bing/Google - seems it may be linked in the Wiki-Coming-Please-link-worthy-posts thread

    indeed thread search for connector hit :: https://forum.pjrc.com/threads/28866...ll=1#post75302

    That links to this :: https://forum.pjrc.com/threads/19336...ll=1#post24468

    Doesn't have the OSHPark board there

  4. #4
    Senior Member
    Join Date
    Jul 2014
    Location
    New York
    Posts
    1,941
    Thanks for posting this. It actually just happened to me but haven't got around to do a search yet on repairing.

  5. #5
    Junior Member
    Join Date
    Nov 2018
    Posts
    2
    @defragster - thanks much - that should do the trick!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •