Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 2 of 2

Thread: Teensy 3.6 prop shield major yaw drift

  1. #1
    Junior Member
    Join Date
    Dec 2018
    Posts
    3

    Teensy 3.6 prop shield major yaw drift

    I purchased a teensy 3.6 and installed a prop shield "Motion Sensor" version. Ran through the https://www.pjrc.com/store/prop_shield.html

    I have never been able to get anywhere close to stable yaw values. It ranges from .5 degrees a second to over 3 degrees a second of drift. A bump changes everything. Recalibration makes no difference.

    Description
    As described here: https://forum.pjrc.com/threads/45173...p+shield+drift
    Yaw is drifting terribly when the board is stable.

    Steps To Reproduce Problem
    Follow all installation and calibration instructions here:
    https://www.pjrc.com/store/prop_shield.html

    Hardware & Software
    Teensy 3.6
    Prop Shield
    Arduino IDE version: 1.8.7
    Teensyduino loader version: 1.44
    VID 16c0
    pid 0483

    Operating system & version Win 7 x64

    So I went and tried everything here:

    https://forum.pjrc.com/threads/45173...p+shield+drift

    And was able to get the dependencies installed and it compiled. Then calibrated via the software provided and that routine. The quaternion results are NaN but everything else feeds back fine. Copied the calibration.h as its required for this one and recompiled. Still nothing.

    How do you get a basic stable yaw value from the compass?
    Last edited by Sharpson; 12-06-2018 at 04:35 AM.

  2. #2
    Senior Member
    Join Date
    Jul 2014
    Location
    New York
    Posts
    1,941
    See the answer to this post where you originally posted the issue: https://forum.pjrc.com/threads/45173...l=1#post192428

    You also try the Kalman Filter version which tends to be more stable.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •