Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 8 of 8

Thread: Teensyduino ide installation issue

  1. #1
    Junior Member
    Join Date
    Dec 2018
    Posts
    4

    Teensyduino ide installation issue

    Hi

    I just installed teensyduino, only for it to start with error messages and rest of gui invisible. GUI elements only became visible when the mouse went over them.

    Initial startup of teensduino:
    Click image for larger version. 

Name:	visible_elements.png 
Views:	7 
Size:	10.9 KB 
ID:	15355

    Error Messages (screenshot taken after mouse on all gui elements to make them visible)
    Click image for larger version. 

Name:	teensyduinoerrors.png 
Views:	14 
Size:	53.8 KB 
ID:	15354


    Prior to installing the teensyduino, the arduio ide started without these errors and all gui visible.

    System Details:
    Teensyduino version: 1.45
    Arduino IDE version: 1.8.8
    OS: Windows 10 home
    Arduino Location: D:\additional apps\arduino-1.8.8
    Arduino has portable folder setup see: https://www.arduino.cc/en/Guide/PortableIDE
    Teensyduino was installed with WIFI off and antivirus turned off
    Teensy LC has not yet been inserted due to ide errors

  2. #2
    Senior Member+ Theremingenieur's Avatar
    Join Date
    Feb 2014
    Location
    Colmar, France
    Posts
    2,117
    Did you try a non-portable installation with Arduino’s standard installer?

  3. #3
    Junior Member
    Join Date
    Dec 2018
    Posts
    4
    Just tried arduino's standard installer (non-portable) followed by the teensyduino installer. Although the gui now worked, the same error messages turned up.

    Error messages screenshot:
    Click image for larger version. 

Name:	teensyduino(nonportableArduinoIDE).png 
Views:	9 
Size:	55.5 KB 
ID:	15356

    Full error messages:
    Code:
    Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
    	at processing.app.EditorLineStatus.setSerialPort(EditorLineStatus.java:136)
    	at processing.app.EditorLineStatus.paintComponent(EditorLineStatus.java:101)
    	at javax.swing.JComponent.paint(JComponent.java:1056)
    	at javax.swing.JComponent.paintChildren(JComponent.java:889)
    	at javax.swing.JComponent.paint(JComponent.java:1065)
    	at javax.swing.JComponent.paintChildren(JComponent.java:889)
    	at javax.swing.JSplitPane.paintChildren(JSplitPane.java:1047)
    	at javax.swing.JComponent.paint(JComponent.java:1065)
    	at javax.swing.JComponent.paintChildren(JComponent.java:889)
    	at javax.swing.JComponent.paint(JComponent.java:1065)
    	at javax.swing.JComponent.paintChildren(JComponent.java:889)
    	at javax.swing.JComponent.paint(JComponent.java:1065)
    	at javax.swing.JComponent.paintChildren(JComponent.java:889)
    	at javax.swing.JComponent.paint(JComponent.java:1065)
    	at javax.swing.JComponent.paintChildren(JComponent.java:889)
    	at javax.swing.JComponent.paint(JComponent.java:1065)
    	at javax.swing.JLayeredPane.paint(JLayeredPane.java:586)
    	at javax.swing.JComponent.paintChildren(JComponent.java:889)
    	at javax.swing.JComponent.paintToOffscreen(JComponent.java:5217)
    	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1579)
    	at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1502)
    	at javax.swing.RepaintManager.paint(RepaintManager.java:1272)
    	at javax.swing.JComponent.paint(JComponent.java:1042)
    	at java.awt.GraphicsCallback$PaintCallback.run(GraphicsCallback.java:39)
    	at sun.awt.SunGraphicsCallback.runOneComponent(SunGraphicsCallback.java:79)
    	at sun.awt.SunGraphicsCallback.runComponents(SunGraphicsCallback.java:116)
    	at java.awt.Container.paint(Container.java:1978)
    	at java.awt.Window.paint(Window.java:3906)
    	at javax.swing.RepaintManager$4.run(RepaintManager.java:842)
    	at javax.swing.RepaintManager$4.run(RepaintManager.java:814)
    	at java.security.AccessController.doPrivileged(Native Method)
    	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
    	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:814)
    	at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:789)
    	at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:738)
    	at javax.swing.RepaintManager.access$1200(RepaintManager.java:64)
    	at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1732)
    	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
    	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
    	at java.awt.EventQueue.access$500(EventQueue.java:97)
    	at java.awt.EventQueue$3.run(EventQueue.java:709)
    	at java.awt.EventQueue$3.run(EventQueue.java:703)
    	at java.security.AccessController.doPrivileged(Native Method)
    	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
    	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
    	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
    	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
    	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
    	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
    	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
    	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

  4. #4
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    18,976
    Ok, I believe I see what's causing the NullPointerException.

    Here's an attempt to fix it. To install this, extract the ZIP file to get pde.jar. Then copy it to the "lib" folder inside Arduino, replacing the pde.jar that's already present.

    Please let me know if this solve the error?
    Attached Files Attached Files

  5. #5
    Junior Member
    Join Date
    Dec 2018
    Posts
    4
    This solves the problem - everything now loads correctly with no errors
    Click image for larger version. 

Name:	workingIDE.png 
Views:	5 
Size:	16.4 KB 
ID:	15358

    Thank you

  6. #6
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    18,976
    Does it also solve the problem when used in portable mode?

  7. #7
    Junior Member
    Join Date
    Dec 2018
    Posts
    4
    Solves the problem for both the installed and portable.

    Thank you

  8. #8
    Junior Member
    Join Date
    Oct 2013
    Posts
    5
    Wanted to say that I also had this issue on a Windows 10 machine, Arduino version 1.8.8 installed as the Windows exe rather than as a Windows 10 App.

    This fix also worked for me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •