*** (I have already solved this problem, solution below... but posting this anyways as documentation in case other beginner users follow the same path I did and run into this error.) ***

I have installed the latest version of the "TeensyDuino" package (v1.45 as listed on the installer), and I am running the Arduino IDE v1.8.8

Following the documentation online here: (https://www.pjrc.com/teensy/td_usage.html) I made sure to have Teensy Loader running in the background before opening up the Arduino IDE, as the documentation states that Arduino IDE needs to use Teensy Loader to communicate to the Teensy. I get this error message when trying to compile any Sketch Examples: " Found Teensy Loader version v1.40, but the minimum required is v1.42. "

Did a quick search online and could not find any download link for a Teensy Loader v1.42.

However following the instructions in the IDE to Quit and restart the Arduino IDE, I realized that Teensy Loader v1.42 is loaded automatically with the Arduino IDE... so Teensy Loader v1.42 must be included inside the TeensyDuino package v1.45. This means that whenever the Arduino needs the Teensy Loader, it pulls the latest version from the installed TeensyDuino package files. In short, no need to have Teensy Loader 1.40 running before opening the Arduino IDE... as long as the latest TeensyDuino package has been installed, Teensy Loader v1.42 is already installed inside of the Arduino IDE.