Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 4 of 4

Thread: Trying to install mcp4278 library to Arduino IDE v.1.8.8?

  1. #1

    Trying to install mcp4278 library to Arduino IDE v.1.8.8?

    I am walking through the steps listed on this github page: https://github.com/Befaco/midithing/

    The instructions link to 3 external libraries (MIDI, Bounce2, and mcp4278) and say to install these to your Arduino IDE. I installed the MIDI and Bounce2 libraries with no issue using Arduino 1.8.8, but when attempting to load the "mcp4728_library_v1.3_for_Arduino_1.0.zip" package, I get an error: "Specified folder/zip file does not contain a valid library."

    I'm not actually even entirely clear on what the mcp4728 library does, as I couldn't find much documentation in the linked repository. So I'm wondering if this may have been built specifically for an older Arduino IDE or possibly different hardware?

    If it makes a difference... I am planning on using this USB AVR Programmer here: https://www.amazon.ca/USBtinyISP-Pro...ogrammer&psc=1

    -Any ideas what the error means? Does this simply mean that this library is outdated and incompatible with my version of the Arduino software?

    -Does anyone know what the mcp4728 library does exactly? Is there possibly a more up to date version of this library which should be used instead?

    Thanks for any input or suggestions!
    Cheers

  2. #2
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    5,679
    Can you tell where exactly is a Teensy involved and which? (3.1, 3.2, 3.5, 3.6 )

  3. #3
    Quote Originally Posted by Frank B View Post
    Can you tell where exactly is a Teensy involved and which? (3.1, 3.2, 3.5, 3.6 )
    I am using Teensy 3.2 generally.

    Ah but I see that as I am not using a Teensy for this application, might be better to bring this to the Arduino Forums. My apologies.

  4. #4
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    5,679
    Just copying the zip-contents to a subfolder of your libraries-folder should work.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •