Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 10 of 10

Thread: Custom teensy 3.6 not work

  1. #1

    Custom teensy 3.6 not work

    Hi everybody,

    I created my custom teensy 3.6 card with a four layer PCB.

    I solder the essential for the power supply, the USB and the MKL02 that I have desolders of an original teensy 3.6 await the delivery MKL02 sold directly by PJRC that I buy. But delivery to France will put at least 2 weeks

    I have the signal on the USB port 0 but nothing happens when I connect to the pc and I press the button reset or reprogramming.

    I suspect the Load Capacitance of this crystals but I do not know how to rectify.

    https://lcsc.com/product-detail/SMD-...pm_C94279.html
    https://lcsc.com/product-detail/49S_...O_C114981.html

    The "MNI" will not be the cause of the problem and the welding is good quality but we never know.
    The vbat is powered by 3.3V.
    I tried Swapping the D + and D- signals on the USB connector.

    I buy the MK66 here and I tested 2.
    https://www.mouser.fr/ProductDetail/841-MK66FX1M0VMD18

    thank you in advance for your help

  2. #2
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    5,403
    https://www.pjrc.com/store/ic_mkl02.html -Scroll down that page for troubleshooting

  3. #3
    Thank you but I already read well and re read what was there on this page.

  4. #4
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    5,403
    Hm, please post your schematic and layout - maybe we can see the issue..

  5. #5
    Here are the parts of the circuit that pose problem. This is my first PCB custom so it's not very nice to see but it will function. And don't laugh
    I tried every combination with the reset and reprog button

    The reset of the PCB filled with other function and the part USB hub function has 100%. And the detention and well 5V and 3.3V. I have not yet check it at the oscilloscope.

    Click image for larger version. 

Name:	Capture.PNG 
Views:	22 
Size:	146.2 KB 
ID:	16017
    Click image for larger version. 

Name:	Capture2.PNG 
Views:	30 
Size:	147.3 KB 
ID:	16018
    Click image for larger version. 

Name:	Capture3.PNG 
Views:	17 
Size:	135.5 KB 
ID:	16019

  6. #6
    PS yes I noticed errors including the level of the retention of the usb 1 but nothing vital to the proper functioning of the MK66

  7. #7
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    19,452
    Looks like VREG_OUT is unconnected on your schematic.

    Pretty sure the USB can't work this way, even if you apply 3.3V to all the other VDD pins. The USB transceiver inside the chip gets its power from VREG_OUT. You need 3.3V power on that pin.

  8. #8
    Hoooo sh***

    In addition I had seen on the page of the store as it was necessary to connect this pin. I forgot it. Thank you Paul.

    I will try to connect it with some stuff.

    As we say here "j'ai le seum".

    Anyway thank you for your help. I hope the problem comes from there.

  9. #9
    Senior Member
    Join Date
    Nov 2012
    Posts
    273
    FE1.1S DP1 (11) connected to MK66 USB0_DM (H2)
    FE1.1S DM1 (10) connected to MK66 USB0_DP (H1)

    doesn't look right

  10. #10
    yes but I already try to cross the cables but it did not change anything.

    I will recommend a PCB with the correction on the voltage of the USB1, connect the DP pin on the DP and DM on DM. and connect the VREG_OUT.

    I have already made the changes but before that I would like to have your opinion about the crystals.

    And if you have any other suggestion do not hesitate . I would like to order it quickly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •