Forum Rule: Always post complete source code & details to reproduce any issue!
Page 2 of 2 FirstFirst 1 2
Results 26 to 27 of 27

Thread: Using a Raspberry Pi Zero W to program a Teensy 3.1/3.2

  1. #26
    Junior Member
    Join Date
    Apr 2019
    Thanks for the detailed reply! This is defenetily the best documentation of this kind of setup I could found.
    But I think I have to except, that I wont be able to do something like that. Thats pretty far out of my ballpark. If nobody with the needed know how will make a step by step documentation or Paul will support some kind of OTA over UART like for other Arduino boards, OTA-Teensy programming will stay a sweat sweat dream for me...
    Even when I would try to follow your already given discription of the setup, I would probablly run into some Issues, where I had no idea how to takle them, cause it was mostly blind flying to get to this point anyway
    Feel free to look into the topic again if you like, but I think that is a lot to ask for... But there would be deffenently more people interesseted than me, tho. It seems to be a lot asked question for years now and there is still no convenient solution to it, even though it would be technical definitely possible with the accessible consumer hardware...

    Anyway, have a nice evening and thanks for your help!

  2. #27
    Junior Member
    Join Date
    Jun 2020
    Richmond, CA
    I apologize for reviving this old thread, but I wanted to note for others that turn up the thread through searching that Arduino 1.8.12 with Teensyduino 1.52 (both current at the time of this post) running under Raspbain 8 (Jessie) can be used to program a Teensy 3.2 from the Pi Zero and Pi Zero W.

    Under Raspbain 10 (Buster) the same combination displays blank Teensy loader window described in post #22.

    A number of years ago I had a similar situation as the OP. We had a Teensy on the garage roof running our holiday lights, and I got tired for getting the ladder out to change it's programming so I threw a Pi Zero with a USB wifi dongle at it, and then VNCed in to it to change the programming and update the Teensy.

    This week I had the need to do something similar again on a new Pi Zero W. I loaded that latest Raspberry Pi OS on it, along with Arduino and Teensyduino, and I just could not get it working, mostly related to the blank Teensy loader window documented in post #22. It would work occasionally, but the times it worked always involved physically pressing the button on the Teensy.

    After coming across this thread, but knowing that I had had it working in the past I decided to start over with the older OS. I loaded up the 2017-03-02 Raspbian Jessie image that I already had laying around. This, conveniently, happens to be the first version that supports the Pi Zero W. I downloaded the current Arduino, Teensyduino and udev rules to it, and it works like a champ. Continued working after apt-get update/upgrade. Verified on both a Pi Zero and Pi Zero W.

    I didn't test any other hardware, so I don't know if this is a Pi Zero thing or an issue with newer Raspberry Pi OS versions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts