Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 12 of 12

Thread: integrating multiple teensy's with a printed circuit , weird synchronization occurs

  1. #1

    integrating multiple teensy's with a printed circuit , weird synchronization occurs

    i designed a PCB to hold a teensy project for a lab i work in .

    there are three teensy's in total which share a few signals , meaning , some of the wires that go to one teensy also go to the others . for example the 3.3V pin and 5V pins connects all three of them (i add the file with all connections) .

    as soon as i connect one of the teensy's to the usb port , something strange happens: the other teensy which is not connected to anything starts blinking . i ignore it and plug in the second one and i am able to upload the program on both . but as soon as i connect the third one it starts to reset it self every second or so .

    what could be the problem ? is there anything acutely wrong with the arrangement i made? i also suspect something went wrong with the reset pin which i connected through all three teensy's to an exterior button .

    i would appreciate any leads , in which way i should start looking to see whats wrong . starting from the question , should it work in theory or is there something i didnt consider when making such arrangement .

    waiting for answers and would provide further details gladly if needed!
    picture of the schematic:
    Click image for larger version. 

Name:	teensyGonySchematic.PNG 
Views:	16 
Size:	465.3 KB 
ID:	16180

    links to pictures of the actuall board
    *notice how only one teensy is connectd yet the next one also blinks (the connected one is U1). it is a bit random , at first it would rapidly reset , now id doesn't reset . also sometimes all three blink in sync , now only U1 vand U3.

    https://photos.app.goo.gl/ruLiLnYE1Ruy1zsu9

    https://photos.app.goo.gl/Dqc6zGVWJAqubcTdA

  2. #2
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    5,567
    Not sure if this is the problem.. the reset pin is an output, too. so if one teensy resets - and this happens when programming , all connected teensys will reset.

  3. #3
    yes i don't think the problem is with the reset pin since only U1 is reseting and also the button seems to work just fine .
    any other ideas ?
    is there anyting wrong with connecting the voltage pins of the teensy's together ? (all GNDs connceted , all 3v3 connected and all Vins - but of course seperately)

  4. #4
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    5,567
    yes if you have the 3v3 pins connected, too , there may be a problem. parallel voltage regs are never a good idea. disconnect them.
    and yes the reset button will work. and the reset-outputs work as described. if not all tensys reset there is something wrong. maybe the internal pullups are too strong for a teensy to reset the others. I dont know its value.

  5. #5
    currently things are working . i didn't really figure out what happened earlier but i suppose it might've been some GND issue cause since i connected the rest of the wiring it works fine.
    one thing i still can't explain is the blinks . even now when i run the program and it is functioning well , there is still a steady blink every second . perhaps you know why?

    also , about your recent comment :
    so you advise me to disconnect the voltage pins from each other ? meaning the 3v3 and the Vin (3.6 to 6 V)

  6. #6
    Senior Member+ Theremingenieur's Avatar
    Join Date
    Feb 2014
    Location
    Colmar, France
    Posts
    2,385
    Vin can and should remain together. GND too. But 3V3 should be separate.

  7. #7
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    5,567
    only disconnect the 3v3s from each other. and reset.
    blink:
    well, something in your software blinks (unless the teensys are not programmed - in this case the blinking is normal).
    Last edited by Frank B; 03-19-2019 at 11:39 AM.

  8. #8
    since the teensy is already soldered to the PCB , is there a way to disable the 3v3 pins by writing a program ?

  9. #9
    Senior Member+ Theremingenieur's Avatar
    Join Date
    Feb 2014
    Location
    Colmar, France
    Posts
    2,385
    Quote Originally Posted by gony View Post
    since the teensy is already soldered to the PCB , is there a way to disable the 3v3 pins by writing a program ?
    No. Cutting traces on the PCB might be an option.

  10. #10
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    19,929
    Quote Originally Posted by gony View Post
    as soon as i connect one of the teensy's to the usb port , something strange happens: the other teensy which is not connected to anything starts blinking . i ignore it and plug in the second one and i am able to upload the program on both . but as soon as i connect the third one it starts to reset it self every second or so .
    These words are very confusing to me. I have no idea what you mean by "starts to reset it self".

    Maybe try telling us what you actually see happening, rather than your interpretation of what is causing it to happen. You may be absolutely correct in your assumption. Or maybe not? But either way, I can not get a clear idea of what you are actually seeing.

    Maybe a photo or quick video (upload to youtube) would be clearest?

  11. #11
    alright , i did it and i think some errors have been resolved .

    about the blinks ; i figured the spare teensy (U3) was the source of it , since it was activated by the shared voltage source and just started running the built-in blink program . then since the 3 teensy's are connected on pin 13 , they all blinked in sync .

    i wanted to upload some blank program to the spare teensy so it won't cause any noise to the other two but when uploading a program from the examples ("DigitalReadSerial" or just a plain code that sets some unused pin as input ) i received the followoing error :
    An error occurred while uploading the sketch
    upload@u3 teensy 3.6 I/O error while writing to '\\.\HID#VID_16C0&PID_0478#6&2E51DD6C&0&0000#{4d1e 55b2-f16f-11cf-88cb-001111000030}'

    any idea what to do about it ? also , is there a way of disabling the entire teensy by code while keeping it connected and ready to upload ?

  12. #12
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    5,567
    void setup(){};
    void loop(){};

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •