Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 5 of 5

Thread: Newly received Teensy 3.5 no longer support USB type - Flight Sim + Joystick

  1. #1
    Junior Member
    Join Date
    Jan 2019

    Newly received Teensy 3.5 no longer support USB type - Flight Sim + Joystick


    I am using the Teensy 3.5 as the controller for my custom joystick.

    For this I am using the USB type: Flight Sim + Joystick

    The first prototype worked well but when I ordered a second AND third Teensy board, the same USB type no longer works.

    Same code/USB type still works on my first Teensy board but not on my other two.

    To solve the problem I select USB type: Keyboard + Mouse + Joystick

    Uninstalling / re-installing everything produces the same results.

    To be a bit more clear, this is what happens when I try to use USB type: Flight Sim + Joystick on the latest Teensy boards.

    - The code compiles without any errors.
    - Windows detects "Teensy Flight Sim Controls" and it appears in "Devices and Printers"
    - When I open "Teensy Flight Sim Controls" Properties, nothing shows up in the test page
    - Same results on different OS and different computer

    With the original Teensy board when I open "Teensy Flight Sim Controls" Properties, I am able to see the axis and buttons so I can test them and make sure everything works correctly.

    Stating the obvious, my end user software doesn't recognize the joystick when this problem is occuring.

    If I load USB type: Keyboard + Mouse + Joystick, windows detects everything and I can use my joystick but its loaded as a keyboard in devices and printers and I need to select the joystick from a drop down menu which is not as "nice"

    I really do not understand what is going on.

    Am I using a counterfeit Teensy?
    Did something change from an older Teensy revision to this newer one?
    Does the library need to be amended to make it work using Flight Sim Control + Joystick?


  2. #2
    Junior Member
    Join Date
    Jan 2019
    Figured it out and thought I would share with everyone.

    There is no problem with the USB type. I tested it in 2 different computers originally that had already used my original Teensy 3.5 joystick.

    When I tested it on a third pc it worked no problem.

    I then had to erase all traces of the original teensy 3.5 Joystick on the other 2 computers and it worked fine.

    Its a bit annoying to have to do this but I guess it is what it is.

  3. #3
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    I have seen notes to that affect - have to change some version info of the USB presented for it to see it as a new device.

  4. #4
    Junior Member
    Join Date
    Jan 2019
    I just go in the registry and delete the joystick instance. Its a bit annoying though since I could be selling this to a client and send a replacement and the client end up having these issues...

  5. #5
    Senior Member+ Theremingenieur's Avatar
    Join Date
    Feb 2014
    Colmar, France
    Please write that to Bill Gates. That's clearly a Windows issue (one of the 9764711)...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts