Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 4 of 4

Thread: ../tools/arm/bin/(build.command.linker) -- "file does not exist"

  1. #1
    Junior Member
    Join Date
    Jun 2019

    ../tools/arm/bin/(build.command.linker) -- "file does not exist"

    I am submitting a bug report post because I could not find a thread for 'file does not exist'.

    I've been using 1.8.8 arduino and teensyduino 1.45 for quite a while with no big issues.
    I upgraded to 1.46 and had this error compiling a program that compiled fine on 1.45:
    .. \\.../tools/arm/bin/(build.command.linker)
    "file does not exist"
    This happened late in the compile process. It kinda looks like the actual linker did not get inserted in the compile string, just the variable name.
    I tried reinstalling 1.8.8 and 1.46 but it did not help. When I tried to reinstall 1.45 over 1.46 it would not let me saying that there were arduino version errors in the ../lib/version.txt file. I checked but it was fine with the string '1.8.8'.

    I finally went back to 1.8.7 arduino and teensy 1.45 and things work again.

    I'm running Windows 7 with Kapersky (file protection was temp off to check if it was part of the problem, it was not).

    Thanks to anyone who can help decipher what went wrong.


  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Inside the Arduino folder, look for platform.txt and boards.txt in hardware/teensy/avr.

    This error means you somehow got one of those files installed, but not the other. How that could happen is a mystery, since both are written by the installer. Only plausible explanation is anti-virus or malware interfering with the installer's ability to write files (but in a subversive way where no filesystem error is reported by Windows to the installer). Yeah, I know you said you disabled auti-virus, but there just isn't any other reasonable explanation.

    I recommend completely uninstalling Arduino, then install a fresh copy, and run the Teensyduino installer on that code (which has neither of these files from a prior install). Or get the ZIP copy from Arduino's website and extract it somewhere else on your hard drive, and install into that copy. But if you use Windows like most people do, that can become very confusing, because Windows may sometimes run the other copy when you click stuff. Having more than 1 copy of Arduino on your PC is possible, but requires careful attention on your part to always know which one you're really using.

  3. #3
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Germany NRW
    if he upgraded from an old version - shouldn't the file be already there?

  4. #4
    Junior Member
    Join Date
    Jun 2019
    Thanks, Paul, for the quick reply. Now I know why pjrc customers are so loyal.
    I downloaded 188 and 189 but the problem persisted, so it may have been a file removal problem with permissions or Kapersky.
    I'll try cleaning out everything and reinstall again soon, when I have more time.
    The really strange thing to me was that the platform.txt file contained a version line of ... 1.8.5 when I used the installer for arduino 1.8.7.

    Really looking forward to the release of 4.0. and sent an email to Robin about pre-orders but I guess she does not have time right now to reply.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts