Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: DIY Teensy 3.2 troubleshooting

  1. #1
    Junior Member
    Join Date
    Feb 2019
    Posts
    7

    DIY Teensy 3.2 troubleshooting

    Hi All,

    Yes - another custom Teensy troubleshooting thread!

    I've built my own but can't get it to work. Before getting into too much detail, can I just check a few things?

    Here's what I've found so far.

    Power appears clean at all power pins - checked with an oscilloscope.
    If I monitor the Reset line, I can see it pulsing (like here: http://www.appfruits.com/2015/03/bui...custom-teensy/ )
    If I ground the Prog line, reset is also pulled to ground
    However, if I monitor the clock and data lines from the MKL04, I can't see anything happening. No clock or data pulses.

    Do I have a faulty/blank MKL04? I can try another one, but reluctant to pull it off my board.

    Thanks!

    Andrew

  2. #2
    Junior Member
    Join Date
    Feb 2019
    Posts
    7
    Hah! Why is it that you post and then solve the problem yourself?

    I have made progress! Silly mistake with soldering. I'd shorted a couple of pins on the MKL04.

    Now able to program the MK20. Not yet working properly, but it's progress...

  3. #3
    Junior Member
    Join Date
    Feb 2019
    Posts
    7
    Actually it is working. Perfectly!

    My PCB design isn't the best - I have lots of lessons learnt, but I do at least have a working DIY Teensy :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •