Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: Annual IDE update and SPI fails

  1. #1
    Junior Member
    Join Date
    Dec 2016
    Posts
    17

    Annual IDE update and SPI fails

    Every year or so I make the mistake of updating the Arduino IDE and Teensy code. Every time it breaks my SPI code. I've completely forgotten what I did last time to get the proper SPI library installed to use SPI0, SPI1, and SPI2 on a Teensy 3.5/6. What am I missing here? (all my existing code complains that SPI1 (or 2) is undefined).

    Any ideas?
    Thanks

  2. #2
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    5,431
    What machine,os,Arduino version, teensyduino version...

    What teensy? Sample showing issue?

    What does compile say? Does it say using library x and not y?

    ...

  3. #3
    Junior Member
    Join Date
    Dec 2016
    Posts
    17
    I figured it out. I had to delete the Arduino SPI libraries before the Teensy libraries would take effect.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •