Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 4 of 4

Thread: Teensy 4 and Arduino IDE on a Mac

  1. #1
    Junior Member
    Join Date
    Aug 2019
    Posts
    2

    Teensy 4 and Arduino IDE on a Mac

    Silly really but I thought I'd get the IDE ready for when I order my unit(s).

    Using an Apple Mac 10.14.6 Arduino 1.8.9 and maybe PlatformIO later on.

    So I installed the software but when selecting a board Teensy 4 is not showing in the menu to select - only the following:

    Teensy 3.6, Teensy 3.5, Teensy 3.2/3.1, Teensy 3.0 and a few more lower level versions.

    It does however compile and open the loader ready but as I'm unable to test with Teensy 4 unit am I missing something or will this work?

    Any help appreciated!

    Roger B
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Screenshot 2019-08-12 at 11.51.17.png 
Views:	3 
Size:	715.4 KB 
ID:	17177  

  2. #2
    Senior Member
    Join Date
    Jul 2014
    Posts
    2,250
    AFAIK, you need TD 1.47b6 for T4 , which you find via https://forum.pjrc.com/threads/54711...l=1#post193715
    Last edited by WMXZ; 08-12-2019 at 11:21 AM. Reason: corrected TD version

  3. #3
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    9,033
    until the release version in next day or so - Latest and Best version is : 1.47-beta6 from msg 2 on the Beta T4 thread.

  4. #4
    Junior Member
    Join Date
    Aug 2019
    Posts
    2
    Thanks both, yes installing the very latest verion (albeit a beta version) gets over the initial problem and seems to compile so I'm now waiting for a unit to try out!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •