I've just started porting my software to T4. I make extensive use of arm_math, and in the past I've had to update arm_math.h to avoid using deprecated routines (which come with a warning that they will be deleted) that are in the 2012 version shipped with Teensyduino. Now with 1.47, the T3 and T4 versions of arm_math are different: T3 has the old 2012 version, while T4 has a newer 2017 version. This means that up to date arm_math code will not compile directly for both T3 and T4.

Of course if you understand the issue, the fix is easy (but annoying) - just continue to update the T3 version with each new install of Teensyduino.

Is it time to make T3 and T4 compatible out of the box??? 2012 happened a long time ago