Hi all,

I'm having a bit of a nightmare using OctoWS2811 board (Teensy 3.2) with a WS2815 led strip.

So... I have a couple of strange things happening.

1. I only seem to be able to get a usable signal from the first twisted pair on my CAT6.
2. I only seem to be ableto transit data to my pixels when I use an LED connector, and not when hard soldered.
3. I get multicolour flickering (mostly white) when I plug in CAT6 into my board (feels like there's no ground to the data etc).

I've recreated this issue on 3 Teensys. I also had this stably working for around a half hour.

Things I've tried/troubleshooting shortcuts:

- Different power supplies. Both beefy 12V 25A-30A.
- Very short cables (both power and signal).
- Different cables.
- Different strips.
- Checking all grounds (Teensy, PSU and strips grounded).
- Grounding LED signal at LED side (as per Paul S advice).
- Trying multiple OctoWS2811 boards.
- Capacitors on each strip (1000nF 25V).
- Tried a WS2812B, which seemed to work fine.

Does anybody have any ideas? It's literally driving me mad.

Best
James

EDIT: I'm driving 4 strips of around 200 pixels, but have also been testing on single strips while trying to sort this issue.