Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: New 4.0 doesn't appear to accept new code

  1. #1
    Junior Member
    Join Date
    Aug 2019

    New 4.0 doesn't appear to accept new code

    I just opened up a new 4.0 and followed the getting started instructions. But the teensy loader app doesn't seem to be working as it is supposed to. I can load a blink program hex file from the examples menu. The app will show the new program and amount of memory used but nothing else happens. In the operation menu, both "program" and "reboot" options are greyed out. The display window of the loader app has never changed to a clear picture of the teensy.

    Prior to loading a new program the pre-loaded blink program appears to be working okay. when I push the load button on the teensy the LED stops blinking as if it has entered program mode. The "auto" options seems to turn on and off but that doesn't appear to change the behaviour at all.

    I would post code but I haven't written any yet. I also tried loading a new program through Arduino IDE. I downloaded the teensyduino plugin and it seems to have worked okay...I can select "teensy 4.0" from the board type. In Arduino IDE, usb type is set to "serial". I attempted to download windows serial installer but windows (Windows home 10) gave a message saying the utility was already present in windows 10 so I didn't follow through with that.

    I also tried to run blink from the Arduino digital examples menu on the off chance that the issue wasn't global but I could not get it to compile successfully. I tried all of the suggested LED pin numbers as well but nothing worked.

    One other relevant possibility is that I may have damaged it somehow soldering pins onto the teensy. I'm a competent solderer, so it wouldn't be my first guess. I've examined the joints under a magnifying lens and there's no sign of bridging. And I'm fairly confident that I didn't overheat anything beyond what a normal solder job would. I used a 30 watt iron and the joints all took easily and quickly as you'd expect.

    There's at least a 50% chance that I messed up the installation somehow. I'm not an experienced user. I have completed one year of EET school so I'm hoping I can figure this out with a little help from the community.

  2. #2
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    With the IDE open open the BLINK example and do a VERIFY build with the Teensy 4 selected as the Board.

    That should complete and then TeensyLoader program noted should open and show the name of the sketch.

    Then press the Button on the Teensy. At that point the image shown should change if only briefly as the upload begins and completes. At the same time as the button press the RED LED on the USB end of the Teensy should light showing it is in bootloader mode with.

    That light should go out shortly and when the code loads the LED on the Button end should begin blinking.

    >> Does any of that not proceed as suggested?

    Modify the timing of the BLINK example to blink at a faster or slower rate - and repeat the process with Verify and the Button or just select Upload.

    What is seen?

  3. #3
    Junior Member
    Join Date
    Aug 2019
    wow...the procedure worked exactly as you described. I'm at a loss to understand why the IDE would not compile before but is working now. But I was able to modify the blink rate no problem. Everything seems to be working perfectly at this time. Thanks for the walk through!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts