Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 5 of 5

Thread: Compiling Teensy 3.2 using JetBrains CLion

  1. #1
    Junior Member
    Join Date
    Aug 2019
    Posts
    1

    Compiling Teensy 3.2 using JetBrains CLion

    The CLion by JetBrains is a nice development environment, but I've been unable to figure out how to configure out how configure CLion to use the GNU toolchain to compile code for the Teensy 3.2 on Mac Os. I was able to install the toolchain and set the $PATH and verify that the toolchain runs, but the details of how to configure CLion (which uses CMake) to build the project have eluded me. I'm working with JetBrains to try and figure this out and, based on the feedback from them, this should be possible. But, unfortunately, while I can code C/C++, I'm not very skilled with configuring the build process.

    Has anyone else tried to use CLion for Teensy development on MacOs? If so, can you provide any pointers, such as a sample project that's set up to compile and build for a Teensy?

    Wayne

  2. #2
    Junior Member
    Join Date
    Sep 2018
    Posts
    13
    A bit late of a reply, however someone else might be interested in using the excellent clion IDE:

    Try the platform.io plugin, you can install it in the configure|plugin section. See here: https://plugins.jetbrains.com/plugin...rmio-for-clion
    It will need an installation of the platformio core https://docs.platformio.org/en/lates...tallation.html
    The platformio plugin contains all current teensy models (not 4.1 at this moment) as one of the many target platforms.

    Check out also https://docs.platformio.org/en/lates...ms/teensy.html where you find hints for configuring USB type, examples etc.

    HTH
    Last edited by scjurgen; 05-29-2020 at 09:44 AM.

  3. #3
    Member
    Join Date
    Apr 2020
    Location
    Germany, NRW
    Posts
    86
    I am wondering about the 4.1 issue because the Visual Studio Version of platformio already includes Teensyduino 1.52 with 4.1.

    https://community.platformio.org/t/t...xpansion/13844

  4. #4
    Junior Member
    Join Date
    May 2020
    Posts
    15
    i am using visual studio with platform io, works perfect.

    teensy 4.1 is fully supported by platformio since about a week:
    https://github.com/platformio/platform-teensy/releases

    cheers

  5. #5
    Junior Member
    Join Date
    Sep 2018
    Posts
    13

    clion+platformio with teensy 4.1

    [QUOTE=mstiller;241509]I am wondering about the 4.1 issue because the Visual Studio Version of platformio already includes Teensyduino 1.52 with 4.1.

    I just updated/upgraded (running Mac OS) and, tada, teensy 4.1 is now supported too

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •