Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 1 of 1

Thread: IO Errors with latest Platform IO and Teensy LC

  1. #1

    IO Errors with latest Platform IO and Teensy LC

    Hi guys, I've been developing on the Teensy LC using Platform IO and VSCode for some time now, but the latest version is having some strange issues which I can't seem to figure out. Basically, the Teensy sometimes refuses to be flashed and spits out a IOError: [Errno 6] Device not configured, either when trying to flash or opening the debug port. Every once in a while, it will work, but often it doesn't.

    Here's the error when opening the debug port:

    Exception in thread rx:
    Traceback (most recent call last):
    File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/threading.py", line 810, in __bootstrap_inner
    self.run()
    File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/threading.py", line 763, in run
    self.__target(*self.__args, **self.__kwargs)
    File "/Users/macuser/.platformio/penv/lib/python2.7/site-packages/serial/tools/miniterm.py", line 445, in reader
    data = self.serial.read(self.serial.in_waiting or 1)
    File "/Users/macuser/.platformio/penv/lib/python2.7/site-packages/serial/serialposix.py", line 467, in in_waiting
    s = fcntl.ioctl(self.fd, TIOCINQ, TIOCM_zero_str)
    IOError: [Errno 6] Device not configured

    This is with known code that has not had any previous issues; I've tried with 3 different Teensy LC chips and get the same result. I've also downloaded VSCode and the latest PIO version on a new computer with the same results.

    Even after pressing the program button, a reflash will often not work. Also, after this situation occurs, sometimes even pressing the hardware reset button fails to reflash and I get a red 'Download Error' on the Teensy program. Any advice? I can upload the hex file that PIO is sending...very confused by this.

    **UPDATE**
    Ok so I've dug a little deeper and I think this has something specifically to do with the I2CT3 library and the latest version of PIO; when I disable my references to this library, everything works fine. Is there a way to go back to an old version of PIO?
    Last edited by vince.cimo; 09-19-2019 at 11:25 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •