So far I'm impressed with the hardware, but I've hit a brick wall with the software. Changes were made to OSX that requires Arduino 1.9.0 beta to even run. There is no way to compile or download code with 1.8.9 on 10.15 because the OS blocks access to the user and download directories by default and 32 bit executable code is flat forbidden. The TeensyDuino installer will fail on the install check for the beta because 1.9.0 is not a valid version. While this may be a good idea in most circumstances, it makes the hardware worthless on a platform that is about to undergo a major OS version change in a few days. Is it possible to get an installer that allows for version 1.9.0?