Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 7 of 7

Thread: DmaSpi library with T4

  1. #1

    DmaSpi library with T4

    Hi,

    is there any chance that this great library will work together with the teensy 4 ?

    https://github.com/crteensy/DmaSpi

    As far i understood with this library you can "deligate" the SPI transfer to a DMA channel and you program can do other things while the data is transferred to the SPI "client", and you can synchronize it via interrupt ?

    Thank you

    Torsten

  2. #2
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    7,415
    Currently it does not build.

    Will took a look

  3. #3
    Hi KurtE,

    Yes it says unknown chip...i thing due to an #ifdef....and i really do not understand what the purpose of this is...so i can't fix it...

    Thank you for your help...

    Torsten

  4. #4
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    7,415
    I did a pass through it to add T4, that it appears like the DMASpi_example1 is working.

    The Fork/Branch is up at: https://github.com/KurtE/DmaSpi/tree/T4

    It might be good if someone else tried it as well. I have not yet tried out using SPI1 or SPI2 with it.

    Edit: Went ahead and issue PR: https://github.com/crteensy/DmaSpi/pull/28

    I tried on SPi1 as well
    Last edited by KurtE; 09-25-2019 at 08:57 PM.

  5. #5
    Hi KurtE,

    thank you very much porting this to teensy 4!

    Torsten

  6. #6
    Quote Originally Posted by KurtE View Post
    I did a pass through it to add T4, that it appears like the DMASpi_example1 is working.

    The Fork/Branch is up at: https://github.com/KurtE/DmaSpi/tree/T4

    It might be good if someone else tried it as well. I have not yet tried out using SPI1 or SPI2 with it.

    Edit: Went ahead and issue PR: https://github.com/crteensy/DmaSpi/pull/28

    I tried on SPi1 as well
    Thanks for doing this, I'm using this for my adventures with DMA and SPI.
    I have a question, I can get SPI0 or SPI1 to work, fab.

    But I can't get DMA for both, I assume I'm doing something wrong, or was the library not designed to do both?

    Thanks in advance
    Paula

  7. #7
    My bad, complete noob error on my part... going to rest my eyes as this was a truly stupid mistake.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •