Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 5 of 5

Thread: Teensy 3.6 on ubuntu, serial monitor is not available

Hybrid View

  1. #1
    Junior Member
    Join Date
    Sep 2019
    Posts
    2

    Teensy 3.6 on ubuntu, serial monitor is not available

    When trying to open the serial monitor, I am getting this error:
    Board at /sys/devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1.3 is not available

    running
    ls -l /dev/serial/by-*

    output:
    /dev/serial/by-id:
    total 0
    lrwxrwxrwx 1 root root 13 Sep 28 14:42 usb-Teensyduino_Teensy_MIDI_Audio_5852970-if00 -> ../../ttyACM0

    /dev/serial/by-path:
    total 0
    lrwxrwxrwx 1 root root 13 Sep 28 14:42 pci-0000:00:14.0-usb-0:2.4:1.0 -> ../../ttyACM0


    running udevadm monitor:
    OUT:
    KERNEL[5005.789357] add /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4 (usb)
    KERNEL[5005.789877] add /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.0 (usb)
    KERNEL[5005.790062] add /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.0/tty/ttyACM0 (tty)
    KERNEL[5005.790092] bind /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.0 (usb)
    KERNEL[5005.790136] add /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.1 (usb)
    KERNEL[5005.790165] bind /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.1 (usb)
    KERNEL[5005.790217] add /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.2 (usb)
    KERNEL[5005.790564] add /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.2/sound/card3 (sound)
    KERNEL[5005.790607] add /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.2/sound/card3/controlC3 (sound)
    KERNEL[5005.790652] add /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.2/sound/card3/midiC3D0 (sound)
    KERNEL[5005.790702] add /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.2/sound/card3/midi3 (sound)
    KERNEL[5005.790717] add /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.2/sound/card3/dmmidi3 (sound)
    KERNEL[5005.790728] add /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.2/sound/card3/seq-midi-3-0 (snd_seq)
    KERNEL[5005.790741] bind /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.2/sound/card3/seq-midi-3-0 (snd_seq)
    KERNEL[5005.790761] bind /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.2 (usb)
    KERNEL[5005.790815] add /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.3 (usb)
    KERNEL[5005.793402] add /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.2/sound/card3/pcmC3D0p (sound)
    KERNEL[5005.793429] add /devices/pci0000:00/0000:00:14.0/usb3/3-2/3-2.4/3-2.4:1.2/sound/card3/pcmC3D0c (sound)


    I'm a complete noob, so please be patient

  2. #2
    Senior Member+ MichaelMeissner's Avatar
    Join Date
    Nov 2012
    Location
    Ayer Massachussetts
    Posts
    3,365
    It is likely one of three things:
    • You didn't install the udev rules;
    • You haven't programmed the Teensy yet. Teensys ship without the serial monitor installed, so when you attach it for the first time, it doesn't create the serial monitor; (or)
    • When you programmed it, you need to select a USB mode that includes the USB serial monitor through Tools -> USB type -> Serial.


    In terms of the udev rule:


    It may be that the udev rules directory is in a different location on your system.

  3. #3
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,789
    ModemManager may be interfering. Ubuntu recently pushed an update that puts ModemManager into a "strict" filter policy setting where it ignores the old udev rules. Whether you consider this behavior of ModemManager to be a bug or feature depends on your perspective. The ModemManager devs did recently fix this, but it will be years until their fix is adopted downstream by Ubuntu and all other distros.

    We recently updated the udev rules file to tell ModemManager to ignore both ports and devices. So make sure you have the newest udev rule file with both ID_MM_DEVICE_IGNORE and ID_MM_PORT_IGNORE.

    Or just uninstall ModemManager if you're not using dialup internet access! But that's not as easy as you might think. ModemManager is s tricky beast to get remove. You might need an apt-get purge or something to actually get it off you system.

  4. #4
    Junior Member
    Join Date
    Sep 2019
    Posts
    2
    figured it out, I needed to just select the port from the ports menu, now serial monitor works

  5. #5
    Junior Member
    Join Date
    Nov 2018
    Posts
    9
    Quote Originally Posted by PaulStoffregen View Post
    We recently updated the udev rules file to tell ModemManager to ignore both ports and devices. So make sure you have the newest udev rule file with both ID_MM_DEVICE_IGNORE and ID_MM_PORT_IGNORE.

    Just a note to say that this change to the udev rule helped me with a standard arduino problem.

    I had a Mint Linux system that had been running arduino (and Teensy) perfectly, using a modified version of the Teensy udev rule file for the arduino. Then suddenly (probably after a Linux update) the avrdude upload to my arduino started failing. Disabling modem manager got things working again. Then I found this udev change for Teensy, applied the change to my arduino udev rule and everything works with modem manager re enabled.
    Last edited by Hughby; 10-09-2019 at 08:45 PM. Reason: So it makes sense!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •