Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 2 of 2

Thread: VS1053b Library and Teensy 4.0

  1. #1
    Junior Member
    Join Date
    Oct 2019
    Posts
    4

    VS1053b Library and Teensy 4.0

    The librarie for VS1053b audio module cannot be compiled on T4 because the initialization routine does not work with 32Bit and T4(?). I've adjusted the init, but I'm afraid that more code will have to be adjusted. The module could not be used until Teensyduino 1.47. Only SDCard was OK, because it runs separately from the VS chip. With 1.48b2 it was better. Realtime MIDI via USB->SDI(SPI)->VS funktionierte dann. But after upload a VS-Plugin to the VS-Modul, the chip suddenly didn't run properly anymore. The Chip seems to be damaged. Nothing came back on T4. I connect it to a STM32 and i can still read and set registers. MP3 Player still works according to Serialmonitor. But there are only undefinable interferences with MP3 Play and SineTest on STM32. Befor the chip was on the STM a while without problems in operation.
    - I don't know if this is a coincidence !! - But I think the module can shows how well the SPI port works because of its sensitivity. A 1.8" TFT works well at the same time.

  2. #2
    Junior Member
    Join Date
    Oct 2019
    Posts
    4
    With a second VS modul i have found the issue. The xreset solder pad has disconnect from conductor track. -.-

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •