Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: Teensy 4 upload problem

  1. #1

    Teensy 4 upload problem

    I have teensyduino running on Kubuntu. I tried the teensy blink demo sketch. It compiles fine, but won't upload to teensy 4.0. I verified I have the right serial port selected, and teensy usb is in serial/bootload mode. I get a popup instructing to press the bootload button on the board. After doing that the red led lights. I then tried the upload again, but get an error message, and response to press the bootload button again. The red led is lit, and the port shows as teensy 4 in boot load mode.
    Is my teensy defective?

    I did solder the ribbon connector for the external SD card to the bottom (teensy 4 breakout board in the blog, I have the exact part number specified in the BOM.) I inspected my soldering under a microscope, looks perfect. I've built many SMT projects and can hand solder 100 pin 0.5mm parts.

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Is the red LED on steady, or blinking slowly?

    Blinking means you have a bad USB cable.

    Did you install the udev rules file? If that is missing, and if the red LED is not blinking, you could expect exactly this behavior (where programs can't access the USB).

    If you have the udev rules installed, the next step is to figure out how to watch syslog to see the kernel messages. On Ubuntu 18 use "tail -f /var/log/syslog". Other distros might use a different log file or somehow with dmesg. Once you can see this, the kernel gives details about USB connect and disconnect events. Those details are the key to figuring out if the hardware is bad, or if the problem is entirely on the Linux side.

    But first double check that udev rules file!

  3. #3
    YES, it was the rules file. I thought I had installed that, but upon checking I saw that I'd only updated the rules files for some AdaFruit boards. I greped the entire rules.d directory for "teensy" and it wasn't there.
    Actually the last time I ran into a udev issue I couldn't even connect to the port via arduino, let alone download. Thanks for jogging my memory on this one!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts