Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 5 of 5

Thread: No sound TEENSY4_AUDIO with Teensy 4.0

  1. #1
    Junior Member
    Join Date
    Oct 2019
    Posts
    5

    No sound TEENSY4_AUDIO with Teensy 4.0

    Hello,
    I Have no sound coming from the headphone.
    I have set every thins like the tutorial
    and the part_1_02_Hardware_Test is correctly loaded on the teensy
    the 3 buttons respond well on the serial port
    the 2 pot too
    and the volume pot is good too
    but I should hear the beep with the headphone connected but no.
    I did try several different headphones
    and also try to connect a loud speaker
    with no succes.

  2. #2
    Member houtson's Avatar
    Join Date
    Aug 2015
    Location
    Scotland
    Posts
    42
    Hi,
    I'm assuming you are using the Audio-board, can you confirm what version of Audio Board it is (it is show on the back of the board, it should be Rev D for Teensy 4) and also please post a picture of your setup cheers, Paul

  3. #3
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    20,835
    Perhaps something isn't connected correctly? We could help much more if you would show photos.

    It's also possible the problem is entirely on the software side. We recently had a similar report of no sound. Here's the thread.

    https://forum.pjrc.com/threads/58007...-on-Teensy-4-0

    If you scroll to the end and check out page 2, as far as we know it was some strange software problem involving missing or wrong libraries (yet no compile error). That one is on my to-do list to later try to figure out how things went so wrong.

    He did get it working by reinstalling Arduino and Teensyduino. See the last message on that thread for details. Maybe give that a try?

  4. #4
    Junior Member
    Join Date
    Oct 2019
    Posts
    5

    No beep problem

    Quote Originally Posted by houtson View Post
    Hi,
    I'm assuming you are using the Audio-board, can you confirm what version of Audio Board it is (it is show on the back of the board, it should be Rev D for Teensy 4) and also please post a picture of your setup cheers, Paul
    OK, I see that I have Audio Board rev C not rev D.
    On my bill it is said: item code:TEENSY4-AUDIO description : Audio Board for use with Teensy 4.0
    But a have received rev C.
    My bill number is 82260

    Click image for larger version. 

Name:	DSC_0552.jpg 
Views:	5 
Size:	59.2 KB 
ID:	18041
    Click image for larger version. 

Name:	DSC_0551.jpg 
Views:	5 
Size:	63.6 KB 
ID:	18042

  5. #5
    Administrator Robin's Avatar
    Join Date
    Oct 2012
    Location
    PJRC Global Headquarters
    Posts
    316
    Quote Originally Posted by PascalAudet View Post
    OK, I see that I have Audio Board rev C not rev D.
    On my bill it is said: item code:TEENSY4-AUDIO description : Audio Board for use with Teensy 4.0
    But a have received rev C.
    My bill number is 82260
    I sent you an email about this. We want to figure out what happened.

    -Robin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •