Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 4 of 4

Thread: Any example code for Teensy 4.0 with ArduCAM Mini to drive an ILI9341 LCD ?

  1. #1

    Any example code for Teensy 4.0 with ArduCAM Mini to drive an ILI9341 LCD ?

    I've got an ArduCAM Mini OV2640 working with Teensy 4.0 thanks to mjs513

    https://github.com/mjs513/WIP/tree/master/ArduCAM_t4

    It can connect to a PC host and capture images.

    Is there any example code to drive an ILI9341 LCD using SPI ?

  2. #2
    Senior Member+ mjs513's Avatar
    Join Date
    Jul 2014
    Location
    New York
    Posts
    4,272
    I have a hacked up version that I did to get this working: https://www.youtube.com/watch?v=Fp0MW_M013o It does use @KurtE's ILI9341_t3n library.
    Attached Files Attached Files

  3. #3
    Thanks for the code mjs513.

    It almost work. I can get a good image on the PC but on the LCD the image looks corrupted. I think some setting is not quite right.

    Click image for larger version. 

Name:	IMG_5004.jpg 
Views:	3 
Size:	158.8 KB 
ID:	18145

  4. #4
    Senior Member+ mjs513's Avatar
    Join Date
    Jul 2014
    Location
    New York
    Posts
    4,272
    Try reducing the SPI clock in the ILI9341_t3n lib, think its configure for #define ILI9341_SPICLOCK 600000000u, try reducing it to 20Mhz as a start. Forgot what I had it set at.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •