Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: Teensy 4.0 CPU Speed Option Not Working Properly !

  1. #1
    Junior Member
    Join Date
    Apr 2017
    Posts
    5

    Teensy 4.0 CPU Speed Option Not Working Properly !

    I do see option to choose Teensy 4.0 CPU Speed from arduino options. But I have seen very weird behavior using some generic functions with different CPU Speed I choose from the option.

    1. delay(1000) -- This function not working same way with CPU Speed Option 600MHz and 24MHz
    2. I also observe SPI is also not normally working with 600MHz option selected while it works with 24MHz.

    So is there any more custom settings required to support generic functions in all CPU Speed selection?

  2. #2
    Junior Member
    Join Date
    Apr 2017
    Posts
    5
    There is detailed discussion about the same here:- https://forum.pjrc.com/threads/58689...rly-!?p=223762

  3. #3
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    10,412
    Indeed TeensyDuino 1.49 beta 3 change should have addressed at least the 24 MHz issue. Some SPI speeds altered using faster clocks - and may be some issue pending in Beta 4.

    If beta 3 is tried and above link or other notes on that Beta3 thread don't address it - then post details to reproduce behavior.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •