Forum Rule: Always post complete source code & details to reproduce any issue!
Page 6 of 6 FirstFirst ... 4 5 6
Results 126 to 131 of 131

Thread: CircuitPython on Teensy 4!

  1. #126
    Well the 7.0.0-rc.2 version seems to have solved this problem for me.
    Thanks very much for helping!

  2. #127
    Senior Member
    Join Date
    May 2015
    Posts
    442
    CircuitPython 7.0.0-rc.3 was posted already too. Looks like it had just one fix for RP2040 over rc2. Following this because I am about to try CircuitPython for a little project using I2C myself.

  3. #128
    Quote Originally Posted by DaQue View Post
    CircuitPython 7.0.0-rc.3 was posted already too. Looks like it had just one fix for RP2040 over rc2. Following this because I am about to try CircuitPython for a little project using I2C myself.
    It seems to be working quite well now. I have 3 I2C devices and an SPI display on it. Turns out a megabyte of ram and 600MHz makes a big difference in how things run. Runs very smoothly. Like buttah. I appreciate the help.

  4. #129
    Junior Member
    Join Date
    Oct 2021
    Posts
    8
    I'm experiencing a problem with PWM output on my Teensy 4.1 using Circuitpython. Does anyone have an idea what could be wrong?

    I've tried following:
    Code:
    import board
    import pwmio
    
    pwmio.PWMOut(board.D1, frequency=1000, duty_cycle=60000)
    But an LED connected to the output of pin 1 does not light up at all. If I try setting the same pin with digital out, then it works. It also works if I use PWM output with C code loaded through the regular Teensyduino IDE. Any ideas?

  5. #130
    Junior Member
    Join Date
    Jan 2016
    Posts
    16
    Quote Originally Posted by Erst View Post
    I'm experiencing a problem with PWM output on my Teensy 4.1 using Circuitpython. Does anyone have an idea what could be wrong?
    It is better to bring up CircuitPython issues in Adafruit spaces. We don't monitor this regularly. Thanks. Please open bug issues like these in https://github.com/adafruit/circuitpython. This particular issue might be covered already in https://github.com/adafruit/circuitpython/issues/4841.

  6. #131
    Junior Member
    Join Date
    Oct 2021
    Posts
    8
    Quote Originally Posted by danhalbert View Post
    It is better to bring up CircuitPython issues in Adafruit spaces. We don't monitor this regularly. Thanks. Please open bug issues like these in https://github.com/adafruit/circuitpython. This particular issue might be covered already in https://github.com/adafruit/circuitpython/issues/4841.
    Ok, it looks like the same problem. I added a comment that the problem persists in v7.0.0. Letís hope the cause is found soon.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •