Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: WAV File Issues

  1. #1

    WAV File Issues

    Hi, long time Teensy fan, new to the Audio Board. I am helping my son with a project, he needs to play his own recorded WAV files in response to button presses. The Teensy and Audio Board are working perfectly, the examples all work using the downloaded SDTEST1 through SDTEST4 files. But we can't get any of our own WAV files to play, not the ones he recorded nor ones we have downloaded from stock sites. Same code, all files on same SD card, just change the file name, and nothing. The serial output seems to indicate that audio is playing for the right duration, but no output. Are there specific requirements for supported WAV files?

    I tried several times to attach the WAV files in a ZIP but it kept throwing an error, so no attachments, not ideal I know. But any ideas would be appreciated.

    Thanks.

    (Looks like I posted this in the wrong forum, can't find a way to move it, sorry!)

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    21,282
    Quote Originally Posted by BenF View Post
    Are there specific requirements for supported WAV files?
    Yes, WAV files need to be 44.1 kHz and 16 bit.

    If you're still having trouble, make a small WAV file (under 1 megabyte as the forum doesn't allow huge files), and try posting that in a zip file.

  3. #3
    That did it, Paul. I must have missed that in the docs. All good now. Thanks as always!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •