Forum Rule: Always post complete source code & details to reproduce any issue!
Page 1 of 2 1 2 LastLast
Results 1 to 25 of 32

Thread: Attempting to connect an AliExpress 1306 OLED to Teensy 4: insta-death :(

  1. #1

    Attempting to connect an AliExpress 1306 OLED to Teensy 4: insta-death :(

    My HW developing career just downfall at the first project

    I plugged USB cable to this Tennsy 4.0 before and it's blink example just ran nicely. After I plugged to this bread-board circuit it blinks never ever, Windows not detected anymore and 0V on Pin #26, 3.3V (250 mA max)

    Can I try to fix this little power guy? (of course I not shorted 5V USB with GND as on the 'plan' - I soldered a hole to 5V USB in reality (also I did not shortened lowest rows pins, only Pin#15 SCK is used on teensy))

    Need to invest into thousands of $ for an ESD workstation?

    I having another Teensy, a 3.2 which sometimes works, sometimes it did'nt. Once produced a weak smog and then I can't reprogram, USB not detects it.

    I tried to push button for 15 s after USB connect - nothing. Red LED not light up.

    Is something wrong whit this circuit (?) - why Teensy died?

    Any help is much appreciated!!!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	Dead Teensy 4.0.jpg 
Views:	35 
Size:	115.0 KB 
ID:	18969   Click image for larger version. 

Name:	Teensy 4.0 plan.jpg 
Views:	25 
Size:	167.0 KB 
ID:	18972  


  2. #2
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    6,546
    Is it still dead when you remove it from the breadboard?

  3. #3
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    10,946
    Given indication the SSD1306 can run on 3.3V - that would have assured only that voltage was in use around the 3.3V Teensy 4 - rather than feeding it 5v from VUSB.

    The i2c 1306's I've used were at 3.3V - though I was sent a board with an i2c 1306 installed and I see it is being fed VCC=5V - and the SDA/SCL pins are at 3.3V

  4. #4
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    6,546
    Yup, the ssd might be the reason - worst case it fed 5v back to the Teensy IO pins (which kills it immedately)

  5. #5
    Quote Originally Posted by Frank B View Post
    Yup, the ssd might be the reason - worst case it fed 5v back to the Teensy IO pins (which kills it immedately)
    Feedback? No any SSD1306 output connected to Teensy input - isn't?

  6. #6
    Quote Originally Posted by Frank B View Post
    Is it still dead when you remove it from the breadboard?
    Of course I immediately removed Teensy from the board - no any sign of life

  7. #7
    Quote Originally Posted by defragster View Post
    Given indication the SSD1306 can run on 3.3V - that would have assured only that voltage was in use around the 3.3V Teensy 4 - rather than feeding it 5v from VUSB.

    The i2c 1306's I've used were at 3.3V - though I was sent a board with an i2c 1306 installed and I see it is being fed VCC=5V - and the SDA/SCL pins are at 3.3V
    I did not played with 3.3V out of Teensy - I thought that 5V USB will do the job as the SSD1306 manual says (if I interpreted well).

  8. #8
    Difficult to say, maybe it is as already said in the other answers.

    Check the following:
    - Inspect your solder point for VUSB, there may be short circuits on the teensy board.
    - If that's okay, stop using the display, you may have got a broken display from China. There are circuits on the display board that can generate approx. 14 volts for the OLED, perhaps such a voltage has been incorrectly fed back to a teensy port

  9. #9
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    21,473
    This connection, if the pins really did go to the same row of 5 pins on the breadboard, will cause the 5V USB power to short to GND.

    Click image for larger version. 

Name:	short.jpg 
Views:	8 
Size:	41.6 KB 
ID:	18980

    This is the path the large current would likely flow:

    Click image for larger version. 

Name:	schematic40.png 
Views:	18 
Size:	109.6 KB 
ID:	18981

    It's possible this large current could have burned the wires on your Teensy. A photo of the bottom side might help.

    You might try to power your Teensy with a 5V power supply connected to the VIN and GND pins. For testing, measure the 3.3V power. If you apply 5V power and the 3.3V power turns on, that's a good sign you may be able to recover. If you do not get 3.3V, odds are slim it will ever work again.

  10. #10
    Quote Originally Posted by larry_berlin View Post
    Difficult to say, maybe it is as already said in the other answers.

    Check the following:
    - Inspect your solder point for VUSB, there may be short circuits on the teensy board.
    - If that's okay, stop using the display, you may have got a broken display from China. There are circuits on the display board that can generate approx. 14 volts for the OLED, perhaps such a voltage has been incorrectly fed back to a teensy port
    Thank You very much! No shortcut around soldered 5V USB.

    I verified all the pins on OLED panel and no more than 3.2V, even when VCC=5V
    Last edited by 10sy; 02-07-2020 at 02:36 PM.

  11. #11
    Quote Originally Posted by PaulStoffregen View Post
    This connection, if the pins really did go to the same row of 5 pins on the breadboard, will cause the 5V USB power to short to GND.

    Click image for larger version. 

Name:	short.jpg 
Views:	8 
Size:	41.6 KB 
ID:	18980

    This is the path the large current would likely flow:

    Click image for larger version. 

Name:	schematic40.png 
Views:	18 
Size:	109.6 KB 
ID:	18981

    It's possible this large current could have burned the wires on your Teensy. A photo of the bottom side might help.

    You might try to power your Teensy with a 5V power supply connected to the VIN and GND pins. For testing, measure the 3.3V power. If you apply 5V power and the 3.3V power turns on, that's a good sign you may be able to recover. If you do not get 3.3V, odds are slim it will ever work again.
    You might be right with this, but from the supplied photo I assumed this is only a female header not going into the breadboard.

  12. #12
    Quote Originally Posted by PaulStoffregen View Post
    This connection, if the pins really did go to the same row of 5 pins on the breadboard, will cause the 5V USB power to short to GND.

    Click image for larger version. 

Name:	short.jpg 
Views:	8 
Size:	41.6 KB 
ID:	18980

    This is the path the large current would likely flow:

    Click image for larger version. 

Name:	schematic40.png 
Views:	18 
Size:	109.6 KB 
ID:	18981

    It's possible this large current could have burned the wires on your Teensy. A photo of the bottom side might help.

    You might try to power your Teensy with a 5V power supply connected to the VIN and GND pins. For testing, measure the 3.3V power. If you apply 5V power and the 3.3V power turns on, that's a good sign you may be able to recover. If you do not get 3.3V, odds are slim it will ever work again.
    As I wrote in the initial post: I did NOT shorten 5V USB to GND (as seen on the cited "plan"). A socket soldered over teensy, it's bottom part is not contacts the breadboard. I thing USB port also would be killed immediately but that port just works fine.

    Also, I having no 3.3V Perhaps 5V to 3.3V converter died? Can I feed 3.3V externally? (see photo) I don't get why You mention external 5V as USB 5V is presents.

    Click image for larger version. 

Name:	P1090725.jpg 
Views:	33 
Size:	145.5 KB 
ID:	18986
    Click image for larger version. 

Name:	P1090723.jpg 
Views:	27 
Size:	137.1 KB 
ID:	18985

  13. #13
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    6,546
    You have connected gnd to vUSB directly on the teensy.

  14. #14
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    6,546
    And what happened to the cpu? It looks not good on the photo

  15. #15
    @Frank B - on the "plan" I did but no in real life! See photo: a socket soldered to 5V USB which is NOT connected to ground (I writing this 3th times). Not really visible well on the photo but VUSB is not shortened with bad soldering.

    Well, the CPU looks not so nice - a sticker was glued on it and I was lazy to clean it yet. In a decent resolution seems terrible - in the real life it is just a bit of glue

    Would be useful to find a reason why Teensy died because if I replace it with a new one that also will die I guess.

    So simple circuit yet deadly

  16. #16
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    6,340
    The difficulty in giving an answer on why it might have died is always a hard question to answer. Obviously if something was shorted out, that can be a very obvious thing to answer.

    I have not used any of the ALiExpress displays, but have played around with a few different SSD1306 displays and never had any issues.

    If it were me, I would try all of the default debug steps. Like remove from breadboard. i.e. remove all exterior wires.

    I would use an external meter and check a few things like, what is the resistance from VIN to VUSB - hopefully connected.
    Then VIN to GND - hopefully very large number. Also 3.3v to GND again hopefully very large number. LIkewise 3.3v to VIN again hopefully large number.

    If you have not already done so, maybe reboot your PC in case the USB port got shorted and turned off...

    Then I would plug in to PC and again check values like: VIN to GND hopefully about 5V, likewise 3.3V to gnd, obviously should be near 3.3V...

    Did your PC then show up any device? If you press down program button for 15-20 seconds does an LED light on the T4? If so release it and the Teensy should revert to the original blink program (NO usb)... If not If so I would then try to program it with another simple program like blink...

  17. #17
    Thanks for the tips. I did the 15S button press without any effect. Of course I immediatelly pulled out Tennsy from the breadboaord. Windows does not play a sound-affect as I plug it in the PC, and does not recognise device at all. No 3.3V - total blackout. I even not downoaded any code to Teensy I just modified Blink's delay values between blinks. Red LED also not turned on anymore.

    PC's USB port was not demaged, works well as before.

    I know it is hard to say anything useful

    R=<1 ohm between VUSB & VIN
    R=1 Mohm between GND & VIN
    R=0.5 Mohm between GND & 3.3V
    V=5V between GND & VIN
    V=0V between GND & 3.3V

    I will try to feed Teensy with 3.3V at that point I signed with red mark on the photo of pure PCB top.
    Last edited by 10sy; 02-07-2020 at 10:54 PM.

  18. #18
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    21,473
    Quote Originally Posted by 10sy View Post
    No 3.3V - total blackout.
    Every Teensy has an power management feature, controlled by the On/Off pin. Normally it can't change if you don't use that pin. If you do, pulling that pin low (it's meant for a pushbutton) for 5 seconds turns off the 3.3V power. Pressing the button for 1/2 second turns the power back on.

    Before you try more aggressive things, check if anything has accidentally connected to that pin. The lack of 3.3V power might be that you've unintentionally turned off the power.

  19. #19
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    10,946
    Quote Originally Posted by Frank B View Post
    There is a missing part between pin 5 and 6.
    Looking at the Card image and a T_4 in hand - that part is not populated from the factory.

  20. #20
    Quote Originally Posted by PaulStoffregen View Post
    Every Teensy has an power management feature, controlled by the On/Off pin. Normally it can't change if you don't use that pin. If you do, pulling that pin low (it's meant for a pushbutton) for 5 seconds turns off the 3.3V power. Pressing the button for 1/2 second turns the power back on.

    Before you try more aggressive things, check if anything has accidentally connected to that pin. The lack of 3.3V power might be that you've unintentionally turned off the power.
    I did not touched any part of Tennsy other than I soldered a minimal amount of pins (MISO was unnecessary for this OLED) - and no, I'm absolutely sure in that I did not touched PRG PIN (as any other non-soldered pins)

    I tried to shorten PROG with GND for a short time but nothing changed

    Why don't You feel that 5V to 3.3V regulator went wrong?

    If I interpreted semantics well a few components generates 3.3V from 5V USB - isn't? How any other components (like an MCU) affects 3.3V???? (sorry I learnt electronics so long time ago we even not learnt digital electronics).

    I going to cut wire after Pin #1 of TLV75733P and feed Teense thru 3.3V line - it is so dangerous?
    Last edited by 10sy; 02-08-2020 at 12:02 AM.

  21. #21
    I can't understand this Pin 5-6 thing. I even not soldered a pin to that "pins" (holes)

  22. #22
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    10,946
    Quote Originally Posted by 10sy View Post
    I can't understand this Pin 5-6 thing. I even not soldered a pin to that "pins" (holes)
    As noted in p#19 - that isn't an issue - those pads appears to ship unpopulated.

  23. #23
    Senior Member
    Join Date
    Jul 2014
    Posts
    2,568
    what is this "CUT" in picture 1090725 ?

  24. #24
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    21,473
    Quote Originally Posted by 10sy View Post
    Can I feed 3.3V externally?
    Yes, but only if 1 of these 2 conditions is true:

    1: The 3.3V power must turn on very quickly, like a physical switch. It must not have a slow rise time, like the soft start of a switching power supply with a large capacitor.

    2: Or, 3V power (or a coin cell) must be first connected to VBAT *before* you apply 3V to the main 3.3V power.

    The reason for this is the SNVS power input must always be applied first or simultaneously with the other power. If you directly power with 3V and the rise time is slow, SNVS will lag behind by 1 diode forward voltage drop. The chip will not boot up if any other pins are powered before SNVS.

  25. #25
    CUT means I separate Teensy's inner parts from 5VUSB->3.3V->Teensy with a cut on PCB indicated by a heirline red line. And then I try to feed 3.3V from a PSU.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •