Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: Empty placeholders in output of arduino-builder

  1. #1
    Member
    Join Date
    Jan 2020
    Location
    Port Elizabeth
    Posts
    51

    Empty placeholders in output of arduino-builder

    I have taken the output of a working sketch for the Arduino IDE that compiles properly and copied the arduino-builder command line:
    Code:
    /home/peter/Downloads/arduino-1.8.12/arduino-builder -dump-prefs -logger=machine -hardware /home/peter/Downloads/arduino-1.8.12/hardware -hardware /home/peter/.arduino15/packages -tools /home/peter/Downloads/arduino-1.8.12/tools-builder -tools /home/peter/Downloads/arduino-1.8.12/hardware/tools/avr -tools /home/peter/.arduino15/packages -built-in-libraries /home/peter/Downloads/arduino-1.8.12/libraries -libraries /home/peter/Arduino/libraries -fqbn=teensy:avr:teensy40:usb=serial,speed=600,opt=o2std,keys=en-us -ide-version=10812 -build-path /tmp/arduino_build_313226 -warnings=default -build-cache /tmp/arduino_cache_954540 -verbose /home/peter/Arduino/projects/flowsen-02/flowsen-02.ino
    /home/peter/Downloads/arduino-1.8.12/arduino-builder -compile -logger=machine -hardware /home/peter/Downloads/arduino-1.8.12/hardware -hardware /home/peter/.arduino15/packages -tools /home/peter/Downloads/arduino-1.8.12/tools-builder -tools /home/peter/Downloads/arduino-1.8.12/hardware/tools/avr -tools /home/peter/.arduino15/packages -built-in-libraries /home/peter/Downloads/arduino-1.8.12/libraries -libraries /home/peter/Arduino/libraries -fqbn=teensy:avr:teensy40:usb=serial,speed=600,opt=o2std,keys=en-us -ide-version=10812 -build-path /tmp/arduino_build_313226 -warnings=default -build-cache /tmp/arduino_cache_954540 -verbose /home/peter/Arduino/projects/flowsen-02/flowsen-02.ino
    I pasted this output into a Linux terminal(Ubuntu 1910), running the commands from the command line.
    This worked. The sketch compiled properly and I could upload it to my Teensy 4.0, where it gave the expected result.

    But the placeholders {} in the output lines were empty. Below is a sampling.
    I can't make head or tail of this. Can anyone tell me why this is so and what I can do to correct it?

    Code:
    ===info ||| Progress {0} ||| [0.00]
    ===info ||| Progress {0} ||| [3.12]
    ===info ||| Progress {0} ||| [3.47]
    ===info ||| Progress {0} ||| [3.82]
    ===info ||| Progress {0} ||| [4.17]
    ===info ||| Progress {0} ||| [4.51]
    ===info ||| Progress {0} ||| [4.86]
    ===info ||| Using board '{0}' from platform in folder: {1} ||| [teensy40 %2Fhome%2Fpeter%2FDownloads%2Farduino-1.8.12%2Fhardware%2Fteensy%2Favr]
    ===info ||| Using core '{0}' from platform in folder: {1} ||| [teensy4 %2Fhome%2Fpeter%2FDownloads%2Farduino-1.8.12%2Fhardware%2Fteensy%2Favr]
    ===info ||| Progress {0} ||| [5.21]
    ===info ||| Progress {0} ||| [5.56]
    ===info ||| Progress {0} ||| [5.90]
    ===info ||| Progress {0} ||| [6.25]
    ===info ||| Progress {0} ||| [6.34]
    ===info ||| Progress {0} ||| [6.42]
    ===info ||| Progress {0} ||| [6.51]
    ===info ||| Progress {0} ||| [6.60]
    ===info ||| Progress {0} ||| [9.72]
    ===info ||| Progress {0} ||| [12.85]
    ===info ||| Progress {0} ||| [15.97]
    ===info ||| Progress {0} ||| [19.10]
    ===info ||| Detecting libraries used... ||| []
    
    ....
    
    ===info ||| Using library {0} in folder: {1} {2} ||| [PollEncoder %2Fhome%2Fpeter%2FArduino%2Flibraries%2FPollEncoder %28legacy%29]
    /home/peter/Downloads/arduino-1.8.12/hardware/teensy/../tools/arm/bin/arm-none-eabi-size -A /tmp/arduino_build_313226/flowsen-02.ino.elf
    ===info ||| Sketch uses {0} bytes ({2}%%) of program storage space. Maximum is {1} bytes. ||| [92256 2031616 4]
    ===info ||| Global variables use {0} bytes ({2}%%) of dynamic memory, leaving {3} bytes for local variables. Maximum is {1} bytes. ||| [119476 524288 22 404812]

  2. #2
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    6,920
    -logger=machine

  3. #3
    Member
    Join Date
    Jan 2020
    Location
    Port Elizabeth
    Posts
    51
    Thanks Frank, that did the job nicely😊

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •