Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 2 of 2

Thread: Ws2811 pixels occasional flashing when white - even when brightness turned right down

  1. #1

    Ws2811 pixels occasional flashing when white - even when brightness turned right down

    I'm wondering if anyone can help me get to the bottom of this issue.

    I've got a pixel matrix controlled by a Teensy 3 with OctoWs2811 shield, 138 x 22 using 6 of the outputs. Software is currently Jinx!

    I'm getting occasional flashes when I set the pixels to white or near white. The brightness is set to half in my Teensy sketch and usually half again in software.

    Even if I turn the brightness down very low I get the flashes but with other colours and patterns it seems fine.

    here's a link to a video

    I don't get it! Anyone got any ideas?

    Thanks.

    Edit*** It just occurred to me that it might be a voltage issue as lighting pixels white uses the most voltage.....I think? I will check the voltage tomorrow. I thought I had sufficient gauge wires and power injection (every 184 pixels) but I should check.

    They are 12V Pixels. I've never really understood how the conversion from 12>5V is done with pixels. But I guess if you have <12V it get's converted to <5V?

  2. #2
    Junior Member ShadowLight8's Avatar
    Join Date
    Nov 2019
    Location
    Indiana
    Posts
    11
    Can you post the code you're running on the Teensy 3? Your video looks similar to an issue I'm seeing with my ws2811 setup.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •