Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: Teensy 4.0 + Rev C Audio Shield + headphones = no audio

  1. #1
    Junior Member
    Join Date
    Feb 2020
    Posts
    4

    Teensy 4.0 + Rev C Audio Shield + headphones = no audio

    I'm not able to hear any audio through the headphones. I'm using the audio example sketches, such as ToneSweep and Guitar. They don't give any errors and the serial outputs seem to be what's expected. I've tested with multiple headphones. I've uploaded other sketches to the Teensy (the blinking LED one) and that worked.
    It's a Teensy 4.0 with the Rev C version of the audio shield. I'm using Mac.

    Here's my setup:

    Click image for larger version. 

Name:	IMG_2299.jpg 
Views:	4 
Size:	100.0 KB 
ID:	19128
    Click image for larger version. 

Name:	IMG_2300.jpg 
Views:	5 
Size:	65.6 KB 
ID:	19129
    Click image for larger version. 

Name:	IMG_2301.jpg 
Views:	5 
Size:	96.0 KB 
ID:	19130
    Click image for larger version. 

Name:	IMG_2302.jpg 
Views:	6 
Size:	80.0 KB 
ID:	19131

  2. #2
    Senior Member
    Join Date
    Nov 2012
    Posts
    1,243
    You need the Rev D board for a Teensy 4.0. The pinouts are a bit different and IIRC there's also an extra resistor in there too. See https://www.pjrc.com/store/teensy3_audio.html

    Pete

  3. #3
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    21,467
    Yes, Rev C is for Teensy 3.x.

    If you use wires to route the signals to the correct pins, Rev C can work with Teensy 4.0. But it will not work when plugged in directly, because the five I2S signals are in the places for Teensy 3.x. They're on different pins for Teensy 4.0.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •