Forum Rule: Always post complete source code & details to reproduce any issue!
Page 3 of 3 FirstFirst 1 2 3
Results 51 to 54 of 54

Thread: In ST7735_t3 : tft.Print and tft.Println do not print spaces

  1. #51
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    7,872
    Good afternoon - The Adafruit display should work with previously defined tab color: tft.initR(INITR_MINI160x80);
    I don't believe theirs is an S... Could be wrong. But fingers crossed should be the same as before... I thought I had one around here, earlier, but don't see it right now, new one should arrive with my Mouser order.

  2. #52
    Senior Member+ mjs513's Avatar
    Join Date
    Jul 2014
    Location
    New York
    Posts
    5,878
    Good Evening
    Yep you are right the Adafruit display works fine with the tft.initR(INITR_MINI160x80); initialization

    What is curious about the display is the datasheet for the display shows a ST7735S? (https://learn.adafruit.com/adafruit-...kout/downloads)

  3. #53
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    7,872
    Good Evening,

    Maybe it also is an S display, but they definitely configured it differently. So will keep fingers crossed that most of them follow one or the other...

    EDIT: Tomorrow or so the new Adafruit display 160x80 will arrive. So of course the one I thought I already had... I just found And looks like it works, the same as yours.

    So looks like I should organize some of my junk! It was buried in my sensors box and not in the displays box. Probably should organize this a lot more!
    Last edited by KurtE; 04-23-2020 at 03:32 AM.

  4. #54
    Junior Member
    Join Date
    Dec 2019
    Posts
    12
    To update the issues that I originally posted about....in case someone is coming across this thread...

    Regarding a .96 80X160 screen like this one https://www.banggood.com/Geekcreit-0...r_warehouse=CN (I mention this because different screens are used in the thread).

    Using ST7735_t3 that can be installed using Teensyduino 1.53 and choosing: tft.initR(INITR_MINI160x80_ST7735S); the issues that I mentioned in my OP are fixed. That option was not available before and results in a modified command set in ST7735_t3. I did not test everything outside of the issues mentioned.

    Even the colors do not need to be #defined as inversion is correctly set. I note that CASET and RASET are set to slightly different values that I had kludged, but they seem to work fine suggesting that I don't completely understand CASET and RASET

    Good Deal!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •