Forum Rule: Always post complete source code & details to reproduce any issue!
Page 3 of 3 FirstFirst 1 2 3
Results 51 to 53 of 53

Thread: In ST7735_t3 : tft.Print and tft.Println do not print spaces

  1. #51
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    6,624
    Good afternoon - The Adafruit display should work with previously defined tab color: tft.initR(INITR_MINI160x80);
    I don't believe theirs is an S... Could be wrong. But fingers crossed should be the same as before... I thought I had one around here, earlier, but don't see it right now, new one should arrive with my Mouser order.

  2. #52
    Senior Member+ mjs513's Avatar
    Join Date
    Jul 2014
    Location
    New York
    Posts
    5,099
    Good Evening
    Yep you are right the Adafruit display works fine with the tft.initR(INITR_MINI160x80); initialization

    What is curious about the display is the datasheet for the display shows a ST7735S? (https://learn.adafruit.com/adafruit-...kout/downloads)

  3. #53
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    6,624
    Good Evening,

    Maybe it also is an S display, but they definitely configured it differently. So will keep fingers crossed that most of them follow one or the other...

    EDIT: Tomorrow or so the new Adafruit display 160x80 will arrive. So of course the one I thought I already had... I just found And looks like it works, the same as yours.

    So looks like I should organize some of my junk! It was buried in my sensors box and not in the displays box. Probably should organize this a lot more!
    Last edited by KurtE; 04-23-2020 at 02:32 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •