Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 2 of 2

Thread: W25Q128FV Memory on Audio Shield

  1. #1
    Junior Member
    Join Date
    Feb 2020
    Posts
    9

    W25Q128FV Memory on Audio Shield

    Hey,

    i tried this example to test if my memory chip is working.
    It seems, that it connects correctly but has an error with reading because it is full.
    I repowered it, and tried to erease data before running this test.
    Nothing helped. Any ideas?

    https://github.com/PaulStoffregen/Se...rdwareTest.ino


    Code:
    Raw SerialFlash Hardware Test
    
    Read Chip Identification:
      JEDEC ID:     EF 40 18
      Part Nummber: W25Q128FV
      Memory Size:  16777216 bytes
      Block Size:   65536 bytes
    
    Reading Chip...
      Previous data found at address 0
      You must fully erase the chip before this test
      found this: 00 01 02 03 04 05 06 07 
      correct: 00 00 00 00 15 F5 95 4B 
    
    Tests Failed  :{
    
    The flash chip may be left in an improper state.
    You might need to power cycle to return to normal.

  2. #2
    Junior Member
    Join Date
    Feb 2020
    Posts
    9
    Okay, found a thread with the same issue.
    Tried another chip and it worked.
    Can be closed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •