Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 7 of 7

Thread: Jetson Nano Teensyduino 1.48 install fails

  1. #1

    Jetson Nano Teensyduino 1.48 install fails

    It was working with Arduino 1.8.9 and Teensyduino 1.47.
    Now Arduino 1.8.10 with Teensyduino 1.48 install is broken on fresh Jetson Nano dev kit SD image https://developer.nvidia.com/embedded/jetpack#install

    arduino-1.8.10-linuxaarch64.tar.xz installs and works using https://www.jetsonhacks.com/2019/10/...etson-dev-kit/
    Install script from arduino.cc fails to install launcher.
    Code:
    slo@sloNano:~/Downloads$ ls
    arduino-1.8.10-linuxaarch64.tar.xz  TeensyduinoInstall.linuxaarch64
    slo@sloNano:~/Downloads$ ./TeensyduinoInstall.linuxaarch64
    Illegal instruction (core dumped)

  2. #2
    Actually, TD 1.48 Beta 1 works as well. It is just the 1.48 release version that fails.

    Please ignore "Install script from arduino.cc fails to install launcher." Because I wanted to test it on a fresh Ubuntu install, I forgot that I hadn't yet changed Nautilus preferences to run scripts on click.

  3. #3
    Junior Member
    Join Date
    Mar 2020
    Posts
    5
    This is a still a problem with the latest releases. One thing to note is the JetsonHacks installer defaults to 1.8.10, but you can update the install script to install a supported version. This doesn't help with the Teensyduino install however.

    The TD 1.48 Beta 1 is no longer available on the forum. Is there a different repository for older build versions?

    I also attempted to build it from source as instructed here however, the ant run fails with the following output:

    Code:
    generate-hourly-build-txt:
    
    start:
    
    linuxaarch64-start:
         [exec] Picked up JAVA_TOOL_OPTIONS: 
         [exec] Set log4j store directory /home/david/.arduino15
         [exec] java.lang.UnsatisfiedLinkError: no splashscreen in java.library.path: [/playpen/Arduino-1.8.12-Teensyduino/build/linux/work/lib, /usr/java/packages/lib, /usr/lib/aarch64-linux-gnu/jni, /lib/aarch64-linux-gnu, /usr/lib/aarch64-linux-gnu, /usr/lib/jni, /lib, /usr/lib]
         [exec] 	at java.base/java.lang.ClassLoader.loadLibrary(ClassLoader.java:2660)
         [exec] 	at java.base/java.lang.Runtime.loadLibrary0(Runtime.java:829)
         [exec] 	at java.base/java.lang.System.loadLibrary(System.java:1870)
         [exec] 	at java.desktop/java.awt.SplashScreen$1.run(SplashScreen.java:134)
         [exec] 	at java.desktop/java.awt.SplashScreen$1.run(SplashScreen.java:132)
         [exec] 	at java.base/java.security.AccessController.doPrivileged(Native Method)
         [exec] 	at java.desktop/java.awt.SplashScreen.getSplashScreen(SplashScreen.java:131)
         [exec] 	at processing.app.Base.<init>(Base.java:241)
         [exec] 	at processing.app.Base.main(Base.java:150)
    
    BUILD FAILED
    /playpen/Arduino-1.8.12-Teensyduino/build/build.xml:140: The following error occurred while executing this line:
    /playpen/Arduino-1.8.12-Teensyduino/build/build.xml:144: The following error occurred while executing this line:
    /playpen/Arduino-1.8.12-Teensyduino/build/build.xml:837: exec returned: 255
    
    Total time: 59 seconds
    Not sure what the return code of 255 is, but it might be related to the amount of memory. Possibly might have more success building on a different machine, but I don't have one handy.

  4. #4
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    12,404
    TD 1.52 just entered Beta - so 1.48 is old … any results with more current TD build

  5. #5
    Junior Member
    Join Date
    Mar 2020
    Posts
    5
    I tried both the release and the current beta, neither worked. Last reported working version was 1.48 beta 1 which is why I am looking for it.

  6. #6
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    12,404
    Quote Originally Posted by qenops View Post
    I tried both the release and the current beta, neither worked. Last reported working version was 1.48 beta 1 which is why I am looking for it.
    Make sure to post link to here or notes on the 1.52 thread so it can be addressed before release with any updates to current behavior.

    Perhaps Paul could repost the needed installer from that version in the meantime if he archives all those interim builds.

  7. #7
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    22,750
    This problem has been fixed in 1.52-beta3. Releases starting with 1.52 should be able to install on Jetson Nano.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •