Forum Rule: Always post complete source code & details to reproduce any issue!
Page 2 of 2 FirstFirst 1 2
Results 26 to 39 of 39

Thread: Teensyduino 1.52 Beta #4

  1. #26
    I'm not sure if this has been addressed, but the same application using the Audio Library compiled on both 1.5.1 and all betas of 1.5.2 fine, but when being programmed by 1.5.2 the teensy doesn't work.

    Any infos on this?

  2. #27
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    6,920
    Quote Originally Posted by MovingAverage View Post
    I'm not sure if this has been addressed, but the same application using the Audio Library compiled on both 1.5.1 and all betas of 1.5.2 fine, but when being programmed by 1.5.2 the teensy doesn't work.

    Any infos on this?
    No, as long we don't have at least a minimal Information what "don't work" means. Have you tried 1.53 or 1.54?

  3. #28
    Excuse my blurry explanation: simple instructions, as setting a pin low for example in the setup() function were not executed (along audio instructions). Additionally, to re-program the teensy, I needed to press the reset button. That's what I meant with "didn't work" The DSP was/is rather memory-heavy, which may have been the reason. Standard Audio-Passthrough worked as expected.

    I just tried to reproduce it with the standard Arduino 1.8.2 application and the Teensyduino 10.8-10.14 installer package, instead of using the bundled application, which seems to work...

    It may just be a special case, but I wanted to ask, as the reason didn't seem clear to me, and maybe someone else encountered the same problem.

  4. #29
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    6,920
    Quote Originally Posted by MovingAverage View Post
    which seems to work...
    We have the 1.54 beta now

    Closing here.

  5. #30
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    12,176
    @Frank - did you mean to close this current "Teensyduino-1-52-Beta-4" thread ?

  6. #31
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    6,920
    opps...got the numbering wrong.. big sorry
    Thank you Tim!

  7. #32
    ...Arduino 1.8.2
    EDIT: I meant the standard Arduino 1.8.12.
    As good as it was working before, the patched Arduino.app suddenly decided to not start anymore (not leaving me any logs whatsoever), which led me to fully uninstall the standard Arduino application and do a clean re-install.

    Again i used the 1.5.2 beta 4 installer but now it gives me the same results on the patched standard Arduino and the standalone Teensyduino.
    Meaning:
    -Compiled w/ Teensyduino 1.5.1 works on Teensy
    -Compiled w/ patched Arduino 1.5.2b4 & Teensyduino 1.5.2b4 "freezes" the Teensy.

    I would like to help but for that I would need to know what to look out for.
    And like I wrote I'm using it with an Audio Library Object which is on the heavy side of memory usage. So this may (or may not) have something to do with it.

  8. #33
    Senior Member
    Join Date
    Oct 2015
    Location
    Roma (IT, EU)
    Posts
    339
    At a minimum, we need to fully reproduce your issue.
    So we need a (possibly minimal) code sample which causes the issue on your side; along with build options. By the way, did you try different build options (say "Smallest Code" vs. "Fast" vs. "Fastest" or the other way around)?

  9. #34
    Is there more information about "Use standard (not low power) ADC mode"
    is it just teensy 4.x that is affected? or will it change performance of 3.x ADC as well?

  10. #35
    Senior Member+ Frank B's Avatar
    Join Date
    Apr 2014
    Location
    Germany NRW
    Posts
    6,920
    Teensy 4.x only.

  11. #36
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    22,458
    Quote Originally Posted by jpk View Post
    on T3.6 Audio ADC input does not compile (vtable error).
    Fixed
    https://github.com/PaulStoffregen/Au...2707180b69eb71

  12. #37
    I just ran the "timeTeensy3" example on a Teensy 4.0 with teensyduino 1.52 beta4. I was expecting the off by one hour error to be gone, but I still see it. I am on a Mac with Catalina.Click image for larger version. 

Name:	Screen Shot 2020-05-13 at 12.44.09 PM.jpg 
Views:	5 
Size:	152.9 KB 
ID:	20098

  13. #38
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Posts
    12,176
    Quote Originally Posted by jrraines View Post
    I just ran the "timeTeensy3" example on a Teensy 4.0 with teensyduino 1.52 beta4. I was expecting the off by one hour error to be gone, but I still see it. I am on a Mac with Catalina.
    Worked on Win 10 - there is now a TD 1.52 B5 release - if possible install and confirm there, not that any changes were done but it will be on current thread to confirm. About to install that here and will check.

  14. #39
    Member
    Join Date
    Oct 2019
    Location
    Calgary
    Posts
    70
    Quote Originally Posted by jrraines View Post
    I just ran the "timeTeensy3" example on a Teensy 4.0 with teensyduino 1.52 beta4. I was expecting the off by one hour error to be gone, but I still see it. I am on a Mac with Catalina.
    Just as a check, in the Teensy Loader, does Help -> About show 1.52-beta-4 or better? I know it sounds unlikely, but there was an earlier case where someone had upgraded, but was still running an older copy of the loader. Assuming of course that there's a separate Teensy Loader program on a Mac; I've read that the Teensy stuff is a little different on a Mac.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •