Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 10 of 10

Thread: New Teensy 4.1 not recognized by Teensy loader

  1. #1
    Junior Member anecdata's Avatar
    Join Date
    May 2020
    Location
    Chicago
    Posts
    5

    New Teensy 4.1 not recognized by Teensy loader

    I've had no trouble with Teensy 4.0s. Plugged Teensy 4.1 into USB (tried several that worked before and after with Teensy 4.0), orange LED blinks. Press the button, red LED comes on, but Teensy loader does not indicate presence or activate the Program UI button. Tried several USBs, several times, Teensy 4.0s always work.

    Tried board reset by holding button for 15 seconds, until red LED blips. Now board has no orange blink. It will enter bootloader (red LED) if I press the button, but same Teensy loader behavior. macOS 10.15.4. Teensy loader 1.48.

  2. #2
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    Posts
    7,629
    It needs the latest beta 1.52 beta 6 to use t4.1.. official release version should be released in the next few days

  3. #3
    Junior Member anecdata's Avatar
    Join Date
    May 2020
    Location
    Chicago
    Posts
    5
    Ah, thanks, makes sense. Is that available for Mac publicly somewhere? I scoured around and could not find it. I found Teensyduino 1.52 beta 6, but not Teensy Loader.

  4. #4
    Senior Member
    Join Date
    Oct 2015
    Location
    Roma (IT, EU)
    Posts
    339
    Teensyduino includes Teensy Loader (in Windows it's "teensy.exe" under Arduino/hardware/tools, don't know about Mac sorry).

  5. #5
    Junior Member anecdata's Avatar
    Join Date
    May 2020
    Location
    Chicago
    Posts
    5
    Thanks for the tip, I found the Mac app in Contents/Java/hardware/tools, and was able to successfully load CircuitPython 5.4.0-beta.0

  6. #6
    Junior Member
    Join Date
    May 2020
    Posts
    14
    new official 1.52 is here... https://www.pjrc.com/teensy/td_download.html

  7. #7
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    22,673
    The stand alone Teensy Loader hasn't been updated. That's next on my list. But for MacOS 10.15 it is not yet set up to be notarized by Apple (without the rest of Teensyduino), so it's not as simple as just putting only a subset of the Teensyduino files into their own archive. Catalina makes everything a bit more complicated....

  8. #8
    Junior Member anecdata's Avatar
    Join Date
    May 2020
    Location
    Chicago
    Posts
    5
    Thanks, Paul. It's all good. We can direct 4.1 users on Mac to the Teensyduino package for now.

  9. #9
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    22,673
    Ok, I've uploaded the 1.52 stand-alone Teensy Loader for Macintosh.

    https://www.pjrc.com/teensy/loader_mac.html

    Please give it a try on your Mac and let me know how it works? If you click Teensy > About, it's version 1.52, and of course should know how to talk to Teensy 4.1.

    This copy is Apple notarized & stapled, so it's supposed to run on Catalina without any security warnings other than the usual notice you downloaded it from the internet, even if you run it when your internet connection is down (without the staple Catalina phones home to Apple to check if it's ok to run). I have only one Mac running Catalina, so I'm really depending on feedback from Mac users.

  10. #10
    Junior Member anecdata's Avatar
    Join Date
    May 2020
    Location
    Chicago
    Posts
    5
    It worked exactly as expected. Thank you!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •