Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 5 of 5

Thread: New Teensy 4.1 has [no_device] error on MacOS 10.14.6; Teensy 3.6 and 4.0 all work

Hybrid View

  1. #1
    Junior Member
    Join Date
    Oct 2018

    New Teensy 4.1 has [no_device] error on MacOS 10.14.6; Teensy 3.6 and 4.0 all work

    I received my first Teensy 4.1 today. I always verify the "factory" Blink appears to be working for each new board and then program a different blink rate to verify that download works. When attempting to select the port in Teensyduino 1.8.12 it shows this:

    [no_device] Bootloader (Teensy 4.1)
    I tried this several times, disconnecting and reconnecting the USB cable. I then verified that the Teensy 3.6 I am currently using works, and then tried the one Teensy 4.0 that I have. It also works.

    Is there a chance that the "15 second" reset might fix this? I wanted to inquire before trying it.

    Can I provide any other information?

  2. #2
    Senior Member+ defragster's Avatar
    Join Date
    Feb 2015
    Not yet seen Harm from 15s Restore. It reloads a no USB Blink factory sketch.

    Then like new - the first upload takes a Button press to get to bootloader and facilitate upload as it comes as noted without USB.

  3. #3
    Senior Member+ KurtE's Avatar
    Join Date
    Jan 2014
    What version of teensyduino is installed?

  4. #4
    Junior Member
    Join Date
    Oct 2018
    Teensyduino 1.52 is installed.

    But I finally got it working. The 15 second reset worked normally. I then stumbled through multiple iterations trying to get the load to work. It was probably a matter of my finger pressing the reset to get to the bootloader, I'm not sure what was going on, but I finally closed the Teensy loader and tried one more time and the loader opened back up and when I pressed reset one more time it started working.


  5. #5
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Glad it finally started working.

    The "[no device]" part means MacOS detected the USB device, but didn't load HID drivers and create a HID entry in the MacOS I/O Registry (or if it did, the teensy_ports program didn't get a notification about the change). Why that would happen is a mystery to me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts