I was investigating an issue I had with using the FastLED library yesterday and noticed that the version included with Teensyduino is currently 3.3.1 from last year (versus the current 3.3.3) with a small modification that now exists in 3.3.3.

This raised the question: where is the punchlist of libraries and versions thereof for Teensyduino maintained?

I'd expect to find the following information about a given package:

  • Name
  • Original repo
  • Original version (e.g., 3.3.3)
  • Fork repo (if forked)
  • Fork version (if forked, e.g., 3.3.3-teensy4 (if possible))
  • A short description of what was forked and why


In the case of FastLED, there appears to be no reason to have a forked version currently. For others, the forked version might be outdated (certainly the case with FastLED, may be others as well).

By having a punchlist like this we could easily see what's going on when it comes to these included and sometimes customized libraries. (Better still if your internal build drove off the same list, if it doesn't do something like that already, to simplify maintenance and ensure consistency.)

This would also help solve another problem: when a user has a library in their main Arduino libraries folder (e.g., via the library manager), it takes precedence over what's included with Teensyduino. It'd be trivial to see what libraries require the Teensy fork by looking at this punchlist.