Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: error: impossible constraint when compiling audio library for Teensy 4.1

  1. #1
    Junior Member
    Join Date
    May 2020
    Posts
    2

    error: impossible constraint when compiling audio library for Teensy 4.1

    I am using Visual Micro plugin for Visual Studio and everything has been working fine with the Teensy 4.1 - love it. That was until I attempted to include the audio library. I get an impossible constraint violation when building with the audio library included. The compiler output is attached. The source code is at https://github.com/bitdog-io/restrai...re-release/src. I first though that the public library might be out of date so I pulled from master on GitHub and replaced the one Visual Micro installed but I still get the error. I changed the build target to Teensy 3.6 and then to Teensy 4.0 and they both built successfully. I then switched to Teensy 4.1 as a build target and it failed again.

    Thank you for your time,
    Vince
    Attached Files Attached Files

  2. #2
    Senior Member PaulStoffregen's Avatar
    Join Date
    Nov 2012
    Posts
    22,109
    Can you try compiling your code in Arduino with Teensyduino 1.52?

  3. #3
    Junior Member
    Join Date
    May 2020
    Posts
    2
    I had to reorganize my project to make it suitable for Arduino and it complied. I used the new project layout for Visual Micro and it compiles as well now. Thank you for your quick response.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •