Forum Rule: Always post complete source code & details to reproduce any issue!
Results 1 to 3 of 3

Thread: Arduino compiler crashes on startup

  1. #1
    Junior Member
    Join Date
    Sep 2019
    Posts
    9

    Arduino compiler crashes on startup

    Beginning just yesterday, my Arduino compiler will no longer run - it just shows the splash screen and then crashes. I read on the Arduino forum that there is a new overnight build that gets around this problem, but after I installed it, I can't install Teensyduino. Apparently they are not compatible???

    HELP! I'm dead in the water......

    Chuck

  2. #2
    Member
    Join Date
    Oct 2019
    Location
    Calgary
    Posts
    60
    From https://github.com/arduino/Arduino/issues/10345

    Due to a server-side issue yesterday (June 10th), the Arduino IDE failed to start due to downloading corrupt board files. The server-side issue has since been fixed, but if you ran into this problem, some manual action is required to make the IDE start again.

    Elsewhere, @cmaglie wrote the following message (adapted with some extra tips):

    We had a problem on our package_index.json that caused the error and prevented the IDE to start.
    Now the package_index has been fixed, but to recover a working installation you must delete once again the package_index.json with the cache folder and restart the IDE as usual.

    Windows (regular version)

    • remove file C:\Users\YourUsername\AppData\Local\Arduino15\pack age_index.json
    • remove folder C:\Users\YourUsername\AppData\Local\Arduino15\cach e


    Note that Windows hides the AppData folder by default. The easiest way to find the right folder is to copy-paste %USERPROFILE%\AppData\Local\Arduino15 into the location bar of an explorer window.

    Windows (Windows Store version)

    • remove file C:\Users\YourUsername\Documents\ArduinoData\cache
    • remove folder C:\Users\YourUsername\Documents\ArduinoData\packag e_index.json


    Mac

    • remove file /Users/YourUsername/Library/Arduino15/package_index.json
    • remove folder /Users/YourUsername/Library/Arduino15/cache


    Linux

    • remove file /home/YourUsername/.arduino15/package_index.json
    • remove folder /home/YourUsername/.arduino15/cache


    Please note that the problem that prevents the IDE to start has already been fixed and it's ready for the next release, that's the reason why the Nightly/Beta Builds are not affected, and also the reason why we did not detect this problem earlier, sorry about that!

    This also means that instead of deleting the above files, upgrading to the latest nightly build or beta build will also allow the IDE to start again (even if you downgrade later).

  3. #3
    Junior Member
    Join Date
    Sep 2019
    Posts
    9
    Thanks! That seems to have fixed the issue.

    Chuck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •